Weird problem with WiFi connection.

Discussion in 'iPod touch' started by GeorgeN111, May 28, 2011.

  1. GeorgeN111 macrumors regular

    Joined:
    May 24, 2010
    #1
    Hello, i have a 3rd generation iPod touch and it has been working perfectly since i brought it more than a year ago. The problem only occurred recently and it has really been bugging me. The iPod shows a connection, usually a 3 bar connection but the problem is when i try to access a webpage on safari or an app such as twitter. The page just wont load. The strange thing is that it will work on certain applications such as the Planet Rock app i use. That works perfectly just as normal. Isn't this strange? I have tried restarting the network, and also a few other methods such as renewing the connection and also forgetting the connection, not of which worked. I also did the thing where the ipod forgets all internet connection details, this too did not work. Does anyone know any thing more about this problem, is this common. Please if you have any ideas on what to do to fix this, please post them. Many thanks, George.
     
  2. slomifier macrumors regular

    Joined:
    Mar 25, 2008
    #2
    Usually the "forget" option fixes it, but sometimes I have to Renew too.

    If you dont have that option, Reserve a ip on your router for your iPod.
     
  3. satointl macrumors member

    Joined:
    Aug 5, 2009
    #3
    Eh, I don't really think it's a problem with the iPod. Try connecting to a different network such as a public place like McDonalds or a public library. Even a friend's house. If the problem is gone, it's your connection/router problem. If it still persists try restoring the iPod. Hope this helps :cool:
     

Share This Page