Weird RAM issue, 2015 5k

Discussion in 'iMac' started by makrom, Mar 25, 2016.

  1. makrom macrumors regular

    Joined:
    Nov 4, 2015
    #1
    I upgraded my RAM with 4 8GB Kingston HyperX 2133MHz (11-12-13) and I get memory errors with Rember. I'm also getting somewhat frequent application and OS X crashes that I neither get on my rMBP nor before the RAM upgrade.
    Rember gave me the following error:
    FAILURE! Data mismatch at local BUFA address 0x0000000496ca2ec8, BUFB address 0x000000082cd426c8
    BUFA Data: 0x7edb584effe57bd9, BUFB Data: 0x7edb584effe57bf9

    Since I couldn't match this memory address to a RAM bank, I tried to test the RAM modules 2 by 2 until I could isolate the culprit.
    But here's the weird thing: The memory issues only occur when I use all 4 modules. When I use any 2, the tests never failed. I tried them in bank 1 and 3 or 2 and 4, but they work fine regardless.

    So basically I can currently use my iMac with 16GB, no matter which modules or banks I am using, but I can't use all 4 at once.
    Is there any way to diagnose what could be the cause for that?
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Return the memory and try a different manufacturer.
     
  3. makrom thread starter macrumors regular

    Joined:
    Nov 4, 2015
    #3
    Well I guess that might work, but returning a non defective product would mean additional costs. Also, couldn't it be a mainboard issue as well?
    Another problem is that there aren't many lv 2133 alternatives available and I went with these since many people here reported them to be working fine in their late 2015 5k iMacs.
     
  4. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #4
    As maflynn said above, you have RAM that's either defective or incompatible with the factory-installed RAM.

    You can return it, or -- live with the crashes.

    Your choice.

    I'd suggest Crucial RAM, or perhaps from this source, which has done well by me with other Macs:
    http://www.datamemorysystems.com/apple-memory/
     
  5. makrom thread starter macrumors regular

    Joined:
    Nov 4, 2015
    #5
    I'm sorry if I phrased it poorly, I don't use it together with the RAM my iMac came with as it only has 4 banks, also the stock RAM only runs at 1866MHz.
    And this particular type of RAM has been reported as working well in these iMac models so I don't think it's incompatible per se. Is there even such a thing as RAM incompatibility that only occurs when using 4 instead of 2 modules?
    To ask in a more specific manner, is there any way to determine which RAM module might be defective, as in matching a memory address to a module? Or is there an effective way to test whether my mainboard might have issues with using 4 modules?
     

Share This Page