Weird rattle noise in iphone 4

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Tedsterb, Oct 20, 2010.

  1. Tedsterb macrumors member

    Joined:
    Apr 1, 2010
    Location:
    WA
    #1
    So when i tap the top part of the phone on my hand, theres a rattling sound i hear inside the phone... very weird. The bottom part doesnt have any noises. I went and asked at the ATT store today and they had no clue. I checked other iphones on display and they all have it.... does yours have it? My old 3G has it too.
     
  2. Storrow macrumors regular

    Joined:
    May 25, 2006
    #2
    I am on my 3rd iphone and they have all done this (swapped out for issues other than the rattling). I think it has something to do with the camera lens. I think they all do it.
     
  3. andybno1 macrumors 68040

    andybno1

    Joined:
    Nov 6, 2007
    Location:
    Liverpool, UK
    #3
    correct it is the camera lens, the rattle does not mean there is anything wrong
     
  4. NicoleRichie macrumors 6502

    Joined:
    Jun 30, 2007
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    If you have a kid give it to them... Most expensive baby rattle ever!
     
  5. Tedsterb thread starter macrumors member

    Joined:
    Apr 1, 2010
    Location:
    WA
    #5
    Haha nice. Well at least its nothing like the new BB Torch, the slider rattles when in the closed position, feels so loose like its about to break off. :(
     
  6. hvgray macrumors newbie

    Joined:
    Apr 9, 2011
    #6
    I found my rattle...

    I took the case off and isolated the rattle: for me it's the power button at the top that has started jiggling back and forth. Gonna keep an eye on it...
     
  7. NutsNGum macrumors 68030

    NutsNGum

    Joined:
    Jul 30, 2010
    Location:
    Glasgow, Scotland
    #7
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    You're right man, it's not the camera lens, it's a loose fitting lock/power button. I took mine in to see about it, because I was finding it incredibly irritating. The genius guy showed me that a few of them did more or less the same thing. Evidently the shape cutting of the lock buttons is a little inconsistent. It's worse on my second iP4 than it was on it my first. I'd recommend getting a bumper, as that pretty much stops it moving around.
     

Share This Page