weird safari "page jump" issue

Discussion in 'iPod touch' started by joeliethegoalie, Mar 2, 2008.

  1. joeliethegoalie macrumors member

    Joined:
    Nov 7, 2007
    Location:
    boulder,co
    #1
    lately I'm experiencing this issue with safari:

    I click a link on one page and it opens a new browser window with the linked page, as it should.

    When I go back to the original page though, that page flips to the page that I had just linked to, with no "back" button available. Thus, I have to reenter the address to navigate back to where I began. It sucks.

    This only started occurring recently. I'm on a wk 38 jailbroken 1.1.2.

    Anyone else experiencing this and/or have a suggestion for a fix?
     
  2. razorianfly macrumors 65816

    razorianfly

    Joined:
    Oct 16, 2007
    Location:
    Cheshire, United Kingdom
    #2
    Un-jailbreak?

    Seriously, I have 1.1.4 un-jailbroken, and I don't have this issue with Safari.

    Seems like another by-product of jail-breaking your device.

    R-Fly
     
  3. domness macrumors 6502a

    domness

    Joined:
    Jan 14, 2008
    Location:
    Sheffield, UK
    #3
    It depends how often you are getting this error..

    It's happened to me in the past with a non-jailbroken phone (i don't get how jailbreaking would make this happen..)

    With me it only happened with a couple of websites, but then I just thought it was the website that made it happen and not the phone..
     
  4. razorianfly macrumors 65816

    razorianfly

    Joined:
    Oct 16, 2007
    Location:
    Cheshire, United Kingdom
    #4
    All kinds of problems have been reported, and proven to be caused by, or are by-products of performing a jail-break. Jail-breaking messes with the frameworks and firmware of the device. Now because 1.1.3 changed the directory applications run in, (they now run as user instead of 'root'), the jail-breaking process could potentially mess up an application, causing it to ball on you.

    After all, the process isn't condoned by Apple, nor was the product made or designed to be 'jail-broken'. :)

    3rd Party applications are coming, more secure and stable ones. I have had the outlook ever since I decided to buy the product, if 3rd party application were available, I would wait for the 'Apple-way'. The secure, and stable way. You guessed it, I'm sitting tight for the fruits of the SDK.

    R-Fly
     
  5. JAT macrumors 603

    Joined:
    Dec 31, 2001
    Location:
    Mpls, MN
    #5
    Once again, ALL THINGS ARE THE FAULT OF A JAILBREAK! :rolleyes:

    You people who don't jailbreak sure know a lot about it. Impressive. I suppose you guys would go into a maternity ward and tell women how it doesn't hurt that much, huh?

    This is a bug that has been in Safari on the Touch since 1.1.1, from what I've seen. I hear it is on 1.1.3 (I'm still 1.1.2), let's hope 1.1.4 fixed it. It only happens with certain websites (forums very notorious), it happens JB'ed or not, and there is a workaround:

    Go back to your original window and quickly hit X to stop it from loading the new window. You don't have to go back quickly since it won't load anything if that window isn't active. But once you go back, quickly hit X.
     
  6. davidy macrumors 6502

    davidy

    Joined:
    Jan 28, 2008
    #6

    as mentioned, jailbraking probably caused the problem. What may work is to touch the page key in the lower right of the screen as if you're adding another page. Then flip back to the page you had linked to and het the red button to delete it. Then flip back to the original page you had.
     

Share This Page