Weird screen bug?

Discussion in 'MacBook' started by spooned12000rpm, Oct 6, 2009.

  1. spooned12000rpm macrumors regular

    Joined:
    Jun 4, 2009
    Location:
    York, UK
    #1
    Ive noticed that when booting and shutting down my macbook there is a wierd coloured line that appears at the top edge of the display when the menu bar isn't present? It's about 1.5 inchs long and only a row of pixels high and to the left of the isight camera and it sort of flickers almost in time with the hdd, any suggestions?

    it does do it all the time and when the menu bar is there it never appears over it which suggests it's not the screen or card? is it something I should just learn to accept or should I get it checked out?
     
  2. backwardsK126 macrumors newbie

    Joined:
    Sep 27, 2009
    #2
    Actually it could very well be the card. I was trying to fix my friends laptop (it was a PC but the same concept) because there were lines going down his screen but once a color (particularly white) covered the lines then they went away. I would take it to the store if I were you and have them check out the graphics card to see whats up
     
  3. KielderWolf macrumors regular

    KielderWolf

    Joined:
    Aug 1, 2009
    Location:
    Northeast England
    #3
    My brother's gaming PC had this same issue shortly before the graphics card died, hopefully unrelated for your sake.

    The line of pixels started about 100 pix into the display and descended in a row 2 pix wide approximately 200 pix in height. When the HDD activity light was lit, the line was cyan, when unlit it was a very dull green (almost too difficult to see on the CRT unless the room light was off).

    And the inexplicable thing was that the line only existed when the screen resolution was set to 1024x768 instead of 1280x1024 (default) - a resolution he commonly used to play games in at higher texture quality without lagging gameplay.

    As I said, the machine only exhibited this symptom for a month or so before £200 worth of ATI graphics processor was reduced to cinders. :(
     
  4. spooned12000rpm thread starter macrumors regular

    Joined:
    Jun 4, 2009
    Location:
    York, UK
    #4
    I should add that it doens't do it all the time, sometimes on bootup other times on shut down but never consistantly, it never appears on the blue screens or on the apple grey screen ???

    Is there anything I can do to test?

    I'm reluctant to take it to my local service provider as they often do naff all but you've got me worried that the GPU is about to die :(

    TBH I'm loosing a bit of faith in Apple, My Blackbook's HDD just died (wouldnt mind but it hadnt ben used for about 2 months)
     
  5. KielderWolf macrumors regular

    KielderWolf

    Joined:
    Aug 1, 2009
    Location:
    Northeast England
    #5
    I know what you mean about loosing faith. Thankfully theres an Apple Store opening in the new Eldon Square branch in Newcastle so I'll have somewhere to go and yell when the inevitable happens. Sorry to hear about the BlackBook, IMHO they were the best MacBooks :(

    On a more upbeat note, if you're running video out and have the MacBook in clamshell mode, does the connected display exhibit the same problem?
     
  6. 13bolducj1 macrumors newbie

    13bolducj1

    Joined:
    Oct 5, 2009
    #6
    I had a very similar problem! I had a colored flickering pixel line going right down to the bottom of my mac screen. About 1.5 inches wide. Took it to a store and they replaced my whole top half of my macbook :rolleyes:
     

Share This Page