Weird scrolling issue

Discussion in 'OS X Mavericks (10.9)' started by djcyke, Nov 9, 2014.

  1. djcyke macrumors newbie

    Joined:
    Apr 9, 2010
    #1
    Hi, apologies if the thread is wrong, or this has been answered already.
    I've searched around the fora, but couldn't find anything similar, could be up2 me.

    As I was installing and trying out some new programs/tools, after a reboot i suddenly noticed that when i tried scrolling down, in ANY window,the scrollbar just automatically starts scrolling back up!!
    Even when I tried to drag the scrollbar down, it won't stay in place, and the application window starts trembling strangely, you can't read the application when you hold the bar down.

    I have this issue in every application with a scrollbar, even when I point the mouse to an app with loads of text buffer, i don't even touch the scroller and it starts scrolling up really fast! :eek:

    As it was in every application windows, first I tried to uninstall every app i installed recently, no result, after I did a PV ram reset on boot, nothing.
    I've been going through the general settings and tried a few scrollbar settings, no changes, and I couldn't find anything related in the systems prefs.

    I've checked the console log, but no errors that point to any mouse and/or scrolling problem, just one WindowServer error that I couldn't find on google.

    As a last resort, I created a new user to logon to my system to check if it is a system or profile error, and lo and behold, the scrolling was back to normal in the new profile.... I had somewhat expected this, but that doesn't really solve my problem, I could migrate my old profile to a new one, but then i might migrate the error, starting fresh is also an option, but it's annoying having to reassess all your settings, possibly reviving programs with serials, and stuff you'll never find back ...

    I really would like to know by now, what ****s up the mouse behaviour so terribly... there must be some .com.apple configuration files one can remove or modify, or defaults.write settings to adjust ? I'll look further in that direction for now, but would be great if any of you has thoughts to share on the issue.

    Thanks.
     
  2. sharon22 macrumors regular

    Joined:
    Oct 19, 2014
    #2
    You, sir, have a VIRUS!
    No, just kidding. Okay, here's what I suspect: you may have a stuck key in your keyboard (sometimes certain key presses, e.g. the spacebar mimics certain mouse behaviors).

    So, here's what you do to "diagnose" this.

    Go into System Preferences / Keyboard

    Then, click on the "Input Sources" tab.

    Then, click on "Show Input Menu in Menu Bar."

    When the keyboard thingy is up in your menu bar, click on that and choose "Show Keyboard Viewer."

    NOW (...finally!), WATCH the little keyboard image, and see if it's showing keys (like the space bar) pressed or not.

    If so, then you just have some stuck keys on your keyboard (requiring careful and appropriate cleaning).

    Please post back if that's what it is! (This is not a "common" occurance, so by you posting back if this helps or not, this could potentially help others with the same problem!).

    Good luck!
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    I'm guessing you installed some malware/adware along with one of those apps.

    Try holding the shift key when starting to boot to safe mode. That will stop any login or hidden startup items (like adware) form launching. Does that fix it?

    If it does, run the app Etrecheck and post the results/output here so we can take a look at what you have installed that might be causing this.
     
  4. djcyke thread starter macrumors newbie

    Joined:
    Apr 9, 2010
    #4
    Thanks for your answer, I tried this without result. no keys moved of flashed when scrolling.

    ----------

    Weaselboy, this indeed worked, booting in Safemode did fix it!

    As I had upgraded to Yosemite, this temporarly fixed the issue, but then i had to reboot.... and it came back !

    Now, to find what is causing this ... must be some startup item somewhere.

    Here is the paste from Etrecheck

    Problem description:
    After installing software, my mouse wont scroll down pages, I cant even drag down the page slider.

    EtreCheck version: 2.0.11 (98)
    Report generated 22 Nov 2014 12:17:33 CET

    Hardware Information: ℹ️
    iMac (27-inch, Late 2009) (Verified)
    iMac - model: iMac10,1
    1 3.06 GHz Intel Core 2 Duo CPU: 2-core
    16 GB RAM Upgradeable
    BANK 0/DIMM0
    4 GB DDR3 1067 MHz ok
    BANK 1/DIMM0
    4 GB DDR3 1067 MHz ok
    BANK 0/DIMM1
    4 GB DDR3 1067 MHz ok
    BANK 1/DIMM1
    4 GB DDR3 1067 MHz ok
    Bluetooth: Old - Handoff/Airdrop2 not supported
    Wireless: en1: 802.11 a/b/g/n

    Video Information: ℹ️
    ATI Radeon HD 4670 - VRAM: 256 MB
    iMac 2560 x 1440

    System Software: ℹ️
    OS X 10.10 (14A389) - Uptime: 0:11:35

    Disk Information: ℹ️
    Hitachi HDE721010SLA330 disk0 : (1 TB)
    S.M.A.R.T. Status: Verified
    EFI (disk0s1) <not mounted> : 210 MB
    OSX 1TB (disk0s2) / [Startup]: 999.35 GB (624.13 GB free)
    Recovery HD (disk0s3) <not mounted> [Recovery]: 650 MB

    PIONEER DVD-RW DVRTS09

    USB Information: ℹ️
    HP Officejet 6500 E710n-z
    Apple Computer, Inc. Apple Cinema Display
    Apple Inc. Built-in iSight
    Apple Internal Memory Card Reader
    Apple, Inc. Keyboard Hub
    Apple, Inc Apple Keyboard
    Arturia Arturia MINILAB
    Thrustmaster Thrustmaster dual analog 3.2
    Apple Computer, Inc. IR Receiver
    Logitech USB Optical Mouse
    Apple Inc. BRCM2046 Hub
    Apple Inc. Bluetooth USB Host Controller

    Firewire Information: ℹ️
    0x1F2 Vendor 0x1F2 Device 0x101800 400mbit - 400mbit max

    Configuration files: ℹ️
    /etc/hosts - Count: 16

    Gatekeeper: ℹ️
    Mac App Store and identified developers

    Kernel Extensions: ℹ️
    /Library/Application Support/Roxio
    [not loaded] com.roxio.TDIXController (2.0) Support

    /Library/Extensions
    [not loaded] com.maudio.usb.fasttrackultra8r.driver (2.4.0 - SDK 10.7) Support
    [not loaded] com.sns.driver.SNSArchitectureModel (1.1.5) Support
    [not loaded] com.sns.driver.Xtarget (1.1.2) Support
    [not loaded] jp.co.roland.RDUSB012FDev (1.5.1 - SDK 10.9) Support

    /System/Library/Extensions
    [not loaded] com.Cycling74.driver.Soundflower (1.6.5 - SDK 10.6) Support
    [not loaded] com.caiaq.driver.NIUSBMaschineControllerDriver (2.5.2 - SDK 10.7) Support
    [not loaded] com.maudio.usb.fasttrack.driver (1.9.2 - SDK 10.6) Support
    [not loaded] com.maudio.usb.venom.driver (1.8.5) Support
    [not loaded] com.motu.driver.FireWireAudio (1.6 59200 - SDK 10.4) Support
    [not loaded] com.motu.driver.MicroBookAudio (1.6 59200 - SDK 10.4) Support
    [not loaded] com.motu.driver.PCIAudio (1.6 59200 - SDK 10.4) Support
    [not loaded] com.motu.driver.USBMidiKext (1.6 59200 - SDK 10.4) Support
    [not loaded] com.nomadesk.driver.VnodeWatcher (3.3.4fc4) Support
    [not loaded] com.paceap.kext.pacesupport.master (5.9 - SDK 10.6) Support
    [not loaded] com.prolific.driver.PL2303 (1.2.1) Support
    [not loaded] com.rane.driver.sixtyeight.10.6 (1.1.2f4) Support
    [not loaded] com.rane.driver.sixtyone.10.6 (1.1.0f1 - SDK 10.6) Support
    [not loaded] com.rane.driver.sixtytwo.10.6 (1.1.0f3 - SDK 10.6) Support
    [not loaded] com.rane.driver.sl2.10.6 (1.0.1f3) Support
    [not loaded] com.rane.driver.sl3.10.6 (1.3.2f6) Support
    [not loaded] com.rane.driver.sl4.10.6 (1.0.1f2) Support
    [not loaded] com.serato.usb.kext (2.3.0) Support
    [not loaded] com.sns.driver.SnsiSCSI (5.2.0) Support

    /System/Library/Extensions/PACESupportFamily.kext/Contents/PlugIns
    [not loaded] com.paceap.kext.pacesupport.leopard (5.9 - SDK 10.4) Support
    [not loaded] com.paceap.kext.pacesupport.panther (5.9 - SDK 10.-1) Support
    [not loaded] com.paceap.kext.pacesupport.snowleopard (5.9 - SDK 10.6) Support
    [not loaded] com.paceap.kext.pacesupport.tiger (5.9 - SDK 10.4) Support

    Startup Items: ℹ️
    Sudochmod: Path: /Library/StartupItems/Sudochmod
    Startup items are obsolete and will not work in future versions of OS X

    Problem System Launch Agents: ℹ️
    [invalid?] com.paragon.NTFS.trial.plist Support
    [invalid?] com.paragon.NTFS.upd.plist Support

    Problem System Launch Daemons: ℹ️
    [failed] com.apple.ucupdate.plist
    [failed] com.apple.watchdogd.plist

    Launch Agents: ℹ️
    [not loaded] com.google.keystone.agent.plist Support
    [not loaded] com.m-audio.fasttrackultra8r.helper.plist Support
    [not loaded] com.motu.MOTULauncher.plist Support
    [not loaded] com.oracle.java.Java-Updater.plist Support
    [not loaded] com.paragon.updater.plist Support
    [not loaded] org.macosforge.xquartz.startx.plist Support

    Launch Daemons: ℹ️
    [not loaded] com.adobe.fpsaud.plist Support
    [not loaded] com.cleverfiles.cfbackd.plist Support
    [not loaded] com.iobit.AMCDaemon.plist Support
    [not loaded] com.m-audio.venom.helper.plist Support
    [not loaded] com.oracle.java.Helper-Tool.plist Support
    [not loaded] com.paceap.eden.licensed.plist Support
    [not loaded] com.paragon.ntfs12.refresh.plist Support
    [not loaded] com.sns.globalSAN.daemon.plist Support
    [not loaded] com.sns.Xtarget.daemon.plist Support
    [not loaded] com.teamviewer.Helper.plist Support
    [not loaded] org.macosforge.xquartz.privileged_startx.plist Support
    [not loaded] org.tcpdump.chmod_bpf.plist Support
    [not loaded] PACESupport.plist Support
    [not loaded] waves.SoundGrid.RawEthernetHelperTool.plist Support

    User Launch Agents: ℹ️
    [not loaded] com.facebook.videochat.[redacted].plist Support

    User Login Items: ℹ️
    Flux Application (/Applications/Flux.app)
    NIHardwareAgent ApplicationHidden (/Library/Application Support/Native Instruments/Hardware/NIHardwareAgent.app)
    DATA UNKNOWN (missing value)
    Dropbox Application (/Applications/Dropbox.app)

    Internet Plug-ins: ℹ️
    nplastpass: Version: 2.0.7 Support
    OVSHelper: Version: 1.0 Support
    Default Browser: Version: 600 - SDK 10.10
    OfficeLiveBrowserPlugin: Version: 12.2.8 Support
    net.juniper.DSSafariExtensions: Version: (null) Support
    Silverlight: Version: 5.1.30317.0 - SDK 10.6 Support
    FlashPlayer-10.6: Version: 15.0.0.189 - SDK 10.6 Support
    Flash Player: Version: 15.0.0.189 - SDK 10.6 Mismatch! Adobe recommends 15.0.0.223
    iPhotoPhotocast: Version: 7.0 - SDK 10.8
    googletalkbrowserplugin: Version: 3.10.2.10212 Support
    npgtpo3dautoplugin: Version: 0.1.44.23 - SDK 10.5 Support
    AdobePDFViewer: Version: 9.4.1 Support
    QuickTime Plugin: Version: 7.7.3
    SharePointBrowserPlugin: Version: 14.0.0 Support
    Becon: Version: (null) - SDK 10.7 Support
    JavaAppletPlugin: Version: Java 8 Update 25 Check version

    User Internet Plug-ins: ℹ️
    Dashlane: Version: Dashlane 1.0.0 - SDK 10.10 Support
    WebEx64: Version: 1.0 - SDK 10.6 Support
    CitrixOnlineWebDeploymentPlugin: Version: 1.0.105 Support
    Google Earth Web Plug-in: Version: 7.1 Support

    Safari Extensions: ℹ️
    AdBlock
    Stop-Reload Button
    SafariRestore
    Dashlane

    Audio Plug-ins: ℹ️
    DVCPROHDAudio: Version: 1.3.2
    SeratoVirtualAudioPlugIn: Version: 1.0.11 Support

    3rd Party Preference Panes: ℹ️
    Air Display Preferences Support
    Fast Track Ultra 8R Control Panel Support
    Flash Player Support
    FUSE for OS X (OSXFUSE) Support
    globalSAN iSCSI Initiator and Xtarget Support
    Growl Support
    Hazel Support
    Java Support
    M-AudioFastTrack Support
    M-Audio Venom Support
    Native Instruments USB Audio Support
    teleport Support
    TVShows Support

    Time Machine: ℹ️
    Skip System Files: NO
    Mobile backups: OFF
    Auto backup: YES
    Volumes being backed up:
    OSX 1TB: Disk size: 999.35 GB Disk used: 375.22 GB
    Destinations:
    TimeMachine [Network]
    Total size: 997.71 GB
    Total number of backups: 35
    Oldest backup: 2014-11-08 23:02:50 +0000
    Last backup: 2014-11-22 09:29:55 +0000
    Size of backup disk: Too small
    Backup size 997.71 GB < (Disk used 375.22 GB X 3)

    Top Processes by CPU: ℹ️
    14% Messages
    8% WindowServer
    1% Safari
    1% hidd
    0% imagent

    Top Processes by Memory: ℹ️
    309 MB Safari
    161 MB WindowServer
    155 MB Dock
    155 MB Messages
    137 MB com.apple.WebKit.WebContent

    Virtual Memory Information: ℹ️
    11.03 GB Free RAM
    4.06 GB Active RAM
    1.10 GB Inactive RAM
    986 MB Wired RAM
    1.59 GB Page-ins
    0 B Page-outs
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    I don't see anything there that is malware or adware, but you do have a LOT of different drivers and utilities running there and I suspect one of those is causing the conflict. The fact the problem goes away in safe mode proves it.

    There is no easy way to fix this other than just removing these items (one by one or in groups) until the problem is fixed. You can use the Etrecheck output as a worksheet since it shows them all and their location.

    Just a couple ideas to start.... I know sound flower has caused a lot of trouble for users.

    Code:
    com.Cycling74.driver.Soundflower
    I would get rid of this one too. It is part of Disk Drill.

    Code:
    com.cleverfiles.cfbackd.plist
    Sorry there is not an easier fix, but trial and error is the only way with this.
     

Share This Page