Weird trackpad problem with MBA, Spotify and TypeIt4Me. A little help?

Discussion in 'MacBook Air' started by coelacanth, Jul 27, 2011.

  1. coelacanth, Jul 27, 2011
    Last edited: Jul 27, 2011

    coelacanth macrumors 6502

    Joined:
    Jul 19, 2004
    #1
    I'm having this weird problem with my MBA11".


    Issue:

    Both built-in trackpad and Magic Trackpad (closed-lid operation with Apple BT keyboard, MT, and 27" Cinema Display) "ignore" the fist tap or click within a few seconds interval. Say if you want to select a tab on Safari, you tap on it. The first tap is ignored, and if you tap again right after that, it is recognized. Operate a few seconds, try tapping on something again, the fist tap is ignored again.

    I narrowed down the circumstances this happens.

    To reproduce:

    On MacBook Air 11" (2011, 4GB/128GB model), preinstalled Lion, run following two applications at the same time:

    • Spotify (downloaded from Spotify website)
    • TypeIt4Me (downloaded from App Store)

    If one or both application(s) are not running, the trackpad WORKS just fine.


    What I've tried:

    Both applications have been erased and reinstalled. No change. Tried in Guest login, same thing.
    Tried same software combination on my 2010 Unibody Mac mini (Lion updated from SL, connected to 27", Magic Trackpad). Similar behavior happens, but (if I'm not imagining things) interval from one "missed tap" from another one feels a lot farther apart compared to MBA.

    I am absolutely clueless at this point, and this is extremely annoying and unproductive as I use my MBA as main machine at work.


    Do you have both Spotify and TypeIt4Me on your MBA on other Macs running Lion? If so could you try the combination and see if you can reproduce the issue? Have you seen anyone having this problem?

    Any info would be greatly appreciated.

    TIA!
     
  2. Cynicalone macrumors 68040

    Cynicalone

    Joined:
    Jul 9, 2008
    Location:
    Okie land
    #2
    I have Spotify on all the time without issue but I don't have the other app.

    If TypeIt4Me changes any of the accessibility settings you might see some strange behavior.
     
  3. coelacanth thread starter macrumors 6502

    Joined:
    Jul 19, 2004
    #3
    Cynicalone,

    Thanks very much for your input.

    You were right. Like Textexpander, TypeIt4Me uses assistive device access, and that was part of the problem. I turn that off, (TypeIt4Me running but not working) and the trackpad issue went away.

    Now, the difference within the Universal Access preference between MBA and the mini was whether it enames dragging with drag lock or not. (enabled only on mini) I changed the setting on MBA to match the mini's and issue looks to be gone. (I don't know if it's completely gone)

    I'll run it this way for a while and see if anything changes. I don't know why Spotify will "activate" this problem but I guess future updates of these apps and the Lion itself will solve the problem at some point.

    Thanks again for chiming in.
     
  4. coelacanth, Jul 27, 2011
    Last edited: Jul 27, 2011

    coelacanth thread starter macrumors 6502

    Joined:
    Jul 19, 2004
    #4
    Another update:

    Mac mini started to show the issue as frequently as MBA did before the change.

    I stopped running TypeIt4Me, turn off the assist device access, start running TI4M again, TI4M prompted to turn on the AD access, then I turned on the AD access again.

    This seemed solving the problem on both MBA and the mini.

    (sad) Update:

    never mind. i needed to log back in to see the the assist access taking place, and as soon as it's enabled, the problem returns. looks like TypeIt4Me is out until this gets solved. :(
     
  5. SidBoggle macrumors regular

    Joined:
    Sep 30, 2007
    Location:
    Bucks, UK
    #5
    I am having the same problem - 11" Macbook air with Typeit4me. When I quit the application everything returns to normal. I have spent ages investigating this issue so glad I finally know what it is.

    I have emailed their support to see if they can comment.
     
  6. SidBoggle macrumors regular

    Joined:
    Sep 30, 2007
    Location:
    Bucks, UK
    #6
    The problem for this has now been found by the developer and I have tested a fixed version which is working fine. Hopefully the update will be in the app store/on his site in the near future.

    In my case it was the program MPlayerX which, when running in the background, would cause the issue with TypeIt4Me but the issue also exists for VLC and Spotify apparently.
     

Share This Page