Weird Trackpad settings reset

Discussion in 'MacBook' started by airjuggernaut, Feb 29, 2008.

  1. airjuggernaut macrumors 6502a

    Oct 16, 2007
    Alright, so I got this weird problem. Every time I unplug my mouse from my Macbook and start using my track pad, the track pad settings get all messed up. The scrolling and double click speed go to the slowest possible setting.
    What gives?
  2. CJFreeman macrumors newbie

    Aug 23, 2008
    Trackpad settings reset

    Hello! I have the same problem sadly on my Macbook Pro - 2.4 Ghz Penryn. Whenever I unplug the mouse I was using, the settings reset. Also, when I toggle from a full screen application to my desktop or some non-full screen application, the speed the mouse moves at seems to reset also. It may do it in other scenarios but I am limiting it to this as that is all I can really be sure of. It is quite annoying...any solutions to these issues would rock. Thanks!
  3. farzin macrumors newbie

    Jul 20, 2008
  4. iLog.Genius macrumors 601


    Feb 24, 2009
    Toronto, Ontario
    Weird. I have the same problem but it's with Apple wireless mouse. Razer mouse settings are fine and when I disconnect it, the trackpad is also fine but when I connect the bluetooth mouse, mighty mouse's setting are reverted back to the default settings. I've tried SMC/PRAM resets but nothing seems to work and I have yet to find a document as to why.
  5. CJFreeman macrumors newbie

    Aug 23, 2008
    Thanks for trying

    I think I may have put my previous post up back when I had more issues than what I have now, but anyway, the dl didn't solve the problem* - as of late, the only issue that I have had is after plugging my razer mouse (deathadder) in, the scrolling speed of my trackpad resets (not the tracking speed, etc.). Idk.
  6. airjuggernaut thread starter macrumors 6502a

    Oct 16, 2007
    lol hey everyone,

    It's been almost a year since I've had that MacBook :p (I now have a MBP)

    To solve this issue, I simply don't install Razer Drivers anymore.

    I just use the standard generic drivers that come with MacOSX.

    You can still assign expose, dashboard, spaces, etc and turn up the mouse sensitivity with System Preferences.

    It much more hassle free :)
  7. farzin macrumors newbie

    Jul 20, 2008
    CJFreeman, try downloading iTool a free app. under the "Preferences Check" option you can run a scan to see if any of your system/user preference files are corrupt.

    have you tried doing an archive and install using the mac os x DVD?
  8. CJFreeman macrumors newbie

    Aug 23, 2008

    I will try out the app you recommended and see if that helps...and no, i have not tried using the OS X disk to repair any just doesn't seem like that sort of issue as it has ALWAYS done this, since I installed the mouse - but I will try that out if the app finds something is corrupt I guess. I'll get back to you.
  9. Lavezzi macrumors member

    Jul 17, 2008
    Sorry to bump this thread, but i'm getting exactly the same problem after installing the newest trackpad firmware that included inertia scrolling.

    Has anyone else found the same?
  10. evanc85 macrumors newbie

    Dec 17, 2011
  11. Riles31 macrumors newbie

    Jun 25, 2011
    Same problem

    Have had non-stop trouble with the trackpad, and would be grateful to hear if there are any recent ideas to fix it.


    MacBook Pro OS X 10.6.8

Share This Page