weird VPN issue (10.5)

Discussion in 'Mac OS X Server, Xserve, and Networking' started by topcomer, Sep 29, 2009.

  1. topcomer macrumors newbie

    Joined:
    Dec 19, 2008
    Location:
    italy/germany
    #1
    Hi,

    I recently signed up a contract with a VPN provider (using PPTP). The issue is that I can connect to all their servers, but only with the windows-based ones I can browse the internet, with the others I can only use Skype. This latter thing would suggest I have a DNS problem, but then how come that windows based servers work?

    Alessio
     
  2. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    #2
    It sounds like a DNS issue indeed. It is possible for the OS X clients not to be using the DNS servers on the tunnel.

    Also, I'd choose something other than a PPTP client if you care anything at all about your data. That's a very weak VPN tunnel.
     
  3. topcomer thread starter macrumors newbie

    Joined:
    Dec 19, 2008
    Location:
    italy/germany
    #3
    thx for the reply.

    is there something I can do to solve the issue? I tried to set the DNS my provider indicates on its website but it didn't help. sorry for the perhaps dumb question but I'm not an expert of networking.

    I use the VPN basically just to watch US and UK streaming from germany (for 3€/month was very convenient), so I think a PPTP would suffice for this purpose.
     
  4. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    #4
    Yeah PPTP should be fine.

    What if you go to Terminal, and do:

    Code:
    nslookup www.google.com <DNS server IP>
    It should work. If not, check your routing table in Terminal:

    Code:
    netstat -rn
    If you post the routing table and the DNS server IPs, I can assist you further.
     
  5. topcomer thread starter macrumors newbie

    Joined:
    Dec 19, 2008
    Location:
    italy/germany
    #5
    I connected to the VPN server, then did tested the two DNS as follows:

    Code:
    alessios-macbook-pro:~ ale$ nslookup www.google.com 216.131.94.5
    Server:		216.131.94.5
    Address:	216.131.94.5#53
    
    Non-authoritative answer:
    www.google.com	canonical name = www.l.google.com.
    Name:	www.l.google.com
    Address: 64.233.169.147
    Name:	www.l.google.com
    Address: 64.233.169.99
    Name:	www.l.google.com
    Address: 64.233.169.103
    Name:	www.l.google.com
    Address: 64.233.169.104
    
    alessios-macbook-pro:~ ale$ nslookup www.google.com 216.131.95.20
    Server:		216.131.95.20
    Address:	216.131.95.20#53
    
    Non-authoritative answer:
    www.google.com	canonical name = www.l.google.com.
    Name:	www.l.google.com
    Address: 64.233.169.99
    Name:	www.l.google.com
    Address: 64.233.169.103
    Name:	www.l.google.com
    Address: 64.233.169.104
    Name:	www.l.google.com
    Address: 64.233.169.147
    
    I saw that in the Network Options in addition to the two DNS I manually set, when I am connected to the VPN, two other IP appear (in gray), which I also tried:

    Code:
    alessios-macbook-pro:~ ale$ nslookup www.google.com 195.242.214.59
    Server:		195.242.214.59
    Address:	195.242.214.59#53
    
    Non-authoritative answer:
    www.google.com	canonical name = www.l.google.com.
    Name:	www.l.google.com
    Address: 74.125.87.99
    Name:	www.l.google.com
    Address: 74.125.87.104
    Name:	www.l.google.com
    Address: 74.125.87.103
    Name:	www.l.google.com
    Address: 74.125.87.105
    Name:	www.l.google.com
    Address: 74.125.87.147
    
    Thank you again.
    Alessio
     
  6. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    #6
    Well DNS is working, so that is fine. Have you tried clearing the browser's cache and then trying to surf?
     
  7. topcomer thread starter macrumors newbie

    Joined:
    Dec 19, 2008
    Location:
    italy/germany
    #7
    I've just tried and it does not work.

    However, if I type "www.google.com", Safari changes it to "www.google.co.uk" so Google somehow sees that I have a UK IP address and I am redirected, but then the page won't load.
     

Share This Page