Weird Wi-Fi

Discussion in 'iPod touch' started by Reddkryten, Sep 24, 2009.

  1. Reddkryten macrumors 6502

    Joined:
    Sep 10, 2009
    #1
    Hello there, I'm wondering has anyone else had this problem with their wi-fi.

    My iPod Touch was working well with my home wi-fi network for the past few weeks. Then about three days ago it suddenly stopped. I can connect to the network, but whenever I try to do anything online I get an "Invalid Argument" error.

    I thought my wi-fi thingy was faulty, but then I borrowed a friends net book and he was able to connect to it without a problem.
    I noticed one thing, the ip address that showed up on the net book was different from the one on the iPod. I tried to manually enter it, but the iPod seemed to forget this as soon as I left settings. Is there any way to make the changes stick?

    Has anyone else had this happen to them, if so, how did you fix it?
    Thanks in advance.
     
  2. macdoofus macrumors member

    Joined:
    Jun 15, 2009
    #2
    That happened to me today today, the first time I ever tried to use Touch wifi. It kept forgetting the network I was logging into. Then I finally got to the "accept terms" or whatever checkbox on the wifi host site. After I accepted terms it went through a-ok and stayed.
     
  3. Reddkryten thread starter macrumors 6502

    Joined:
    Sep 10, 2009
    #3
    Hi, thanks for the tip.

    Unfortunately the network I am trying to log into does not have a login/terms and conditions screen. It's just, connect to wi-fi and browse.

    Any ideas?
     
  4. csnplt macrumors 6502

    csnplt

    Joined:
    Aug 29, 2008
    Location:
    Chicago Area
    #4
    If nothing else helps, you could try a restore of your iPod touch. You could also try resetting your router, which I would do first. First, just turn it off and on again. If it still doesn't work, reset the router's settings, and reconfigure it. If it still doesn't work, try restoring the touch.

    Good luck.
     
  5. masterapple04 macrumors regular

    Joined:
    May 26, 2004
    Location:
    Massachusetts, USA
    #5
    Mine was doing something similar a couple of weeks ago. It would not automatically connect to my remembered networks. A quick restore solved all of my problems, so I'd listen to the above poster and do that.
     
  6. Reddkryten thread starter macrumors 6502

    Joined:
    Sep 10, 2009
    #6
    Hi there.

    I tried restoring the iPod about 20 minutes ago, no luck.
    However, once i had restored it, I reloaded from a backup, so that could explain why it didn't work. Whatever has become corrupted is stored in the backup.

    Is there any way for me to save my calender, notes and contacts, so I can do a totally fresh restore of the iPod?
     
  7. cottonjenn macrumors member

    Joined:
    May 4, 2009
    #7
    How did you manually change the IP address? I'm having a problem also where the IP address on the iPod is different from my router. It sees it but not really connecting and no one can tell me how to change it. I've called Apple and they had me reset the iPod but didn't know how to change the IP address. No one seems to be able to answer that question.

    Also what is considered the network name? I'm so confused with all these terms, network name, security?-is that my password. I tried playing around doing different things. Some people suggested downloading the firmware of the router but I don't want to mess with my computer settings.
     
  8. Reddkryten thread starter macrumors 6502

    Joined:
    Sep 10, 2009
    #8
    Hi there.

    Manually entering the ip is easy, just go into wifi, find your connection of choice, click the little arrow to go into the advanced section. Then you'll see three things at the top of the screen(DHCP, BootP and Static), one of them is labeled static. Click static and enter the info there.

    I actually managed to fix it last night (well, a friend with years of IT experience) by bringing out a laptop and using that to find router and DNS numbers, then entering those.

    Ta-Dah!
     
  9. wallapaloo macrumors newbie

    Joined:
    Nov 1, 2008
    #9
    Serious Wi-fi Problem

    I have a linksys wireless g-broadband router that has been working great, until recently. There are 2 PCs and 1 Mac that are always connected to the router. There is occasionally another Mac and PC that join the network. Recently though the router has not been able to assign an ip address for any of the PCs and if it can, it lasts a short time. Then we added an iPod touch to the network, and it barely works at all.

    The iPod and the Macbook seem to have no problem connecting to the network, but will boot the PCs off the network. I have reset the router; reprogrammed it; changed it from WEP to WPA2; upgraded to the latest firmware; and tried to give each computer a static ip address, all of which didn't help. I decided that it my be specifically the iPod and tried to change its settings from DHCP to static, but the changes didn't stay.

    Can anyone help with this problem? Should I get a new router?
     

Share This Page