weird wifi issue - no networks showing.

Discussion in 'MacBook Pro' started by zenapple, Oct 21, 2015.

  1. zenapple macrumors newbie

    Joined:
    Oct 21, 2015
    #1
    I have a 2008 MBP that started acting weird. At first the wifi triangle was grey with a "!" on it and said, "hardware not found" - I just did a clean install of Yosemite in there and the wifi option came back and it seems it's searching for networks but none of the wifi networks show up.

    I searched the web for an answer but no luck.

    Any idea?

    Much appreciated.

    zenapple
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Hey ZenApple,

    I'll be honest, 'hardware not found' is never a good sign. However there's something you can try.

    Restart your computer with 'Reopen windows when logging back in' disabled

    If this still doesn't work, click the Wi-Fi icon and then click the Network Preferences (I think it's called that, basically one of the bottom options). It should take you to the System Preferences network settings. Where the drop-down list is next to Network Name, are they visible there?

    a) If they are visible here, but not visible in the top Wi-Fi menu, please go to:

    1) Macintosh HD > Library > Preferences
    2) The Preferences folder will likely have a red error icon by it. Right-click it, click 'Get Info', unlock the folder, and add your user with read and write privileges.
    3) Close this dialogue box, open the Preferences folder, and search for the 'System Configuration' folder.
    4) Rename 'System Configuration' to 'System Configuration 1', then restart the computer. Should fix the issue.

    b) If they are not visible here, it's probably not good. Try see if the hardware appears in system information. To do this, click the Apple icon at the top-left, and hold the 'Alt' key. 'About this Mac' should now change to 'System Information'. Click this and see if your Wi-Fi card is visible in here.

    Speak soon.
     
  3. zenapple thread starter macrumors newbie

    Joined:
    Oct 21, 2015
    #3
    Hi,

    Thanks for taking your time and responding so fast.

    I tried as you said and still nothing. The list is empty in the top bar wifi icon drop down and also in the system preferences network area. However when I go to system report and look under "Wifi" lot's a specs are there so it seems the hardware is recognised.

    Thanks
     
  4. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #4
    Hi Zen, sorry I've got 'auto monitor threads' disabled by default so just quote this and I'll ensure I pick it up :)

    Right, few more things to try. If you try renaming that System Configuration folder anyway and restart, see what happens. If that doesn't fix the issue, can you try creating a new user account and see if it's working through that?

    EDIT: if still no luck, try resetting PRAM & SMC. Any luck?
     
  5. zenapple thread starter macrumors newbie

    Joined:
    Oct 21, 2015
    #5
    Hi again,

    I just did those two things and still the same. I'm starting to think that it might be indeed a hardware related issue. Not to big of a deal, planning on putting it on eBay anyway but would have been nice of the wifi to work.

    thanks for taking your time buddy
     
  6. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #6
    Not to worry matey, sorry we couldn't fix the issue. If there's an Apple Store local it may be worth popping in there briefly so they can boot from a FireWire drive or something, just to 100% confirm the problem. Definitely does seem hardware related though.
     
  7. zenapple thread starter macrumors newbie

    Joined:
    Oct 21, 2015
    #7
    Not anywhere nearby an applestore at the moment.

    I appreciate your help.

    Enjoy your day
     

Share This Page