Weird Youtube problem desperately needs solving(are you up for a challenge?)

Discussion in 'OS X Mavericks (10.9)' started by emir, Nov 7, 2013.

  1. emir macrumors 6502a

    emir

    Joined:
    Apr 5, 2008
    Location:
    Istanbul
    #1
    Hi;

    My friend has been having this incredibly weird problem in her computer for more than a couple of months now and she decided to ask me for help because, well, I like Apple products and follow the news and am a veteran mac user etc... So she figured I could solve it. However I can't. Hope you guys can help because this is really weird and annoying at the same time.

    She has a 2009 15" Macbook Pro and the problem it has is it can't connect to youtube.com. No matter what she does, which browser she tries, no connection to youtube. It just says "waiting for IP" I tried typing youtube's IP directly to the browser and it didn't work either. No links of youtube from google or someplace else does not work. No embed video plays. I tried restoring the hosts file incase it was changed by some app. I erased cookies, web cache, flushed the IP, changed Dns.... nothing worked. She was using Snow Leopard and I updated it to Mavericks, still no change. Googleing the problem is hard and there aren't much solutions out there either.

    She can not completely delete the entire OS and reinstall it because there are expensive paid apps such as Traktor. So can you good people of MacRumors think of a good suggestion?

    Thanks in advance, Cheers.

    p.s. accidentally opened this thread in Mountain Lion forum. Didn't know a way to carry it so opened it here as well hope it's not an issue.
     
  2. xylitol macrumors regular

    Joined:
    Nov 2, 2013
    Location:
    Finland
    #2
    Might be a modem/router issue. Have you tried with another computer or her computer on another internet connection?
     
  3. Hungry&Foolish Suspended

    Joined:
    Mar 29, 2012
    #3
    In some countries youtube is blocked. Firefox has unblock youtube extension.
    Try opendns router setting.
     
  4. w0lf macrumors 65816

    w0lf

    Joined:
    Feb 16, 2013
    Location:
    USA
    #4
    Yeah it could be a router issue maybe.

    Have you tried going to youtube through a proxy website?
     
  5. dumb macrumors member

    Joined:
    Nov 1, 2009
    #5
    I'm sure you may have tried, but any entries for youtube in host file ?

    $ sudo nano /private/etc/hosts
     
  6. emir thread starter macrumors 6502a

    emir

    Joined:
    Apr 5, 2008
    Location:
    Istanbul
    #6
    I have tried with other computers on the same router, did work with no problems. Tried the same computer with other networks, still can't connect to youtube. Youtube is not blocked on my country (Turkey) It was blocked for a couple of months over taxing issues a few years ago but now it's not. Also the same computer was having the same problem in France as well.

    However the computer can connect to youtube via websites such as ktunnel.com I think those are proxy sites.

    As I've mentioned in the original post I've checked the "hosts" file, no entries on youtube there.

    So, this is super weird, anyone else has any ideas? Please?
     
  7. ElliottG macrumors member

    Joined:
    Sep 19, 2013
    #7
    If she has legally purchased apps like Traktor, why doesn't she have the install discs or at least the installer files? I'm sure that if she legally paid for them she could easily get them again...

    That way you could reinstall the OS and it'll probably solve everything.
     
  8. emir thread starter macrumors 6502a

    emir

    Joined:
    Apr 5, 2008
    Location:
    Istanbul
    #8
    It's just too much work to do for a youtube problem only. There are too much documents and apps. Surely there must be a workaround for this problem.

    In a nutshell;

    -Can access youtube via proxy sites such as ktunnel or tunnel
    -Changing DNS or router does not work
    -Hosts file does not have a entry for youtube
    -clearing cache and cookies do not work
     
  9. tejpatil macrumors newbie

    Joined:
    Jun 8, 2013
    #9
    Check if her laptop ip address/mac address has been blocked to access Youtube website on the routers access restriction settings. Usually this type of issue happens in those cases. Or it might be a add-on the web browser that is blocking somewebsites. So check add-ons on web browser.
     
  10. emir thread starter macrumors 6502a

    emir

    Joined:
    Apr 5, 2008
    Location:
    Istanbul
    #10
    I tried all three web browsers and I don't think it's the router cause it's not like the computer can't connect on one network. It can't connect at home, school, work, any other wifi network including the ones in France when she was abroad.

    So since I can access it through proxy websites, something in the OS is blocking youtube access but if it's not "hosts" then what is it?
     
  11. xylitol macrumors regular

    Joined:
    Nov 2, 2013
    Location:
    Finland
    #11
    Does she use a firewall like Little Snitch?

    Did she use a proxy to access Youtube when it was blocked in your country? Maybe the proxy is still enabled, but it is now blocked by Youtube for some reason. Check System prefs, Network, Advanced, Proxies.
     
  12. emir thread starter macrumors 6502a

    emir

    Joined:
    Apr 5, 2008
    Location:
    Istanbul
    #12
    that could be the reason. I'll check and give you guys an update later on. Cheers.
     
  13. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #13
    Check the firewall settings in System Preferences and I would also try another account (even if you have to make one) to see if it is something account specific or computer specific. You can also try the private browsing within Safari and see if it works with the Private Browsing setting, so it could be something that is related to the tracking and cookies/ caches??
     
  14. nzalog macrumors 6502

    Joined:
    Jul 25, 2012
    #14
    Can you ping youtube.com from the computer?
    can you ping 74.125.239.129 if not youtube.com?
     
  15. emir thread starter macrumors 6502a

    emir

    Joined:
    Apr 5, 2008
    Location:
    Istanbul
    #15
    Ok so this problem is driving me insane.

    -There are no firewalls installed on the computer, firewall on the mac is off.
    -Problem still occurs on the guest account of the mac.
    -No access to youtube still while private browsing either.
    -I tried pinging, it can't ping youtube.
    -Checked the hosts file, only entries are for adobe, no entry for youtube or anything that could be related.
    -There are no proxy settings everything is unchecked.
    -No browser works, not only Safari.

    It obviously is a network setting problem but I can't find out what is blocking the connection to youtube only.

    She said she has installed this app to her mac on the days youtube was blocked in the country for taxation reasons and I searched it. What the app does is it edits the hosts file and adds entries for youtube. After the banning of youtube was removed in the country she still could connect to it. Then one day out of the clear blue sky it started not connecting. That app is uninstalled now and hosts file has no entry other than adobe and that is for creative suite obviously. What might be the problem it's super weird.

    Thanks a lot for the help people.
     
  16. dastinger macrumors 6502a

    dastinger

    Joined:
    Mar 18, 2012
    #16
    Did you check the router settings to see if there's a setting regarding YouTube blocking that would only work on her computer (by Mac address per example)?
     
  17. vanc macrumors 6502

    Joined:
    Nov 21, 2007
    #17
    What's the output from "traceroute youtube.com"? Run the command in Terminal.
     
  18. nzalog macrumors 6502

    Joined:
    Jul 25, 2012
    #18
    Did you try the IP I told you to ping? It's the resolve youtube IP. Just trying to determine if it's dns or not.
     
  19. kmpoboy2 macrumors 6502

    kmpoboy2

    Joined:
    Jul 10, 2010
    Location:
    Alabama
    #19
    Is there any chance that the YouTube ip is mixed with the blocked adobe creative suit ones?
     

Share This Page