Weirdest Problem, please HELP - Macbook crashes when I plug-in the battery

Discussion in 'MacBook' started by aponsin, Apr 7, 2009.

  1. aponsin macrumors member

    Joined:
    Mar 28, 2009
    #1
    Hi,

    I have googled that issue but could not find anything on it...

    My second generation black macbook has always been working perfectly until last night... I was watching a movie on my external monitor, when the computer kinda a froze, became irresponsive etc... Rare but ok. I reboot the machine (it was plugged in with the power source and battery inside).

    The machine won't start... so I remove the battery, reset the PVRAM, etc. The usual things. The computer restart just fine with only the power cord plugged in but not the battery.
    I tried to plugged the battery when the computer was running and it crashed it immidiately: this weird black screen that appears really really rarely saying that I need to reboot.
    Ok, I reboot with the battery in, I hear the optical drive makes it's bzzz bzzz sound as usual, but the screen won't turn on, no chime, nothing.

    I remove the battery again still plugged in, but it won't start... I finally reallized that I need to do the reset thingy apple + command + power button with everything unplugged (battery and power cord) to have the computer restart after I placed the battery inside...

    I don't understand.. what could be wrong ? My battery ? It's fully charged... it was showing pretty good health last time I check (99%).

    Any ideas? It's kinda of big pain to have a laptop that needs to stay plugged in.

    Thanks,

    Alex
     
  2. brop52 macrumors 68000

    brop52

    Joined:
    Feb 26, 2007
    Location:
    Michigan
    #3
    I don't know if you properly did the SMC and PRAM resets by your description so I'll write them here.

    First, shut down, unplug the magsafe, take out the battery, and hold down the power button for at least five seconds. Next, put everything back and hold down command-option-P-R at startup until it chimes twice and then let it start up normally.

    If those don't help then start up from the Leopard DVD and run the hardware test by holding down D at startup and let it run.
     
  3. aponsin thread starter macrumors member

    Joined:
    Mar 28, 2009
    #4
    Thanks for the advices.. but I tried the SMC multiple times, it's actually the only things that brings the laptop back to life after I put the battery in.

    When I put the battery in, it never goes to the chime... I only hear the optical drive initialize, and actually sometime up to 3 times in a row...

    When I remove the battery, do the SMC reset and restart only with the magsafe in (no battery) it boots and works just fine....

    Regarding the OSX hardware thingy, I don't have it with me, and I would not be able to boot on it with the battery inside...

    Alex
     
  4. flopticalcube macrumors G4

    flopticalcube

    Joined:
    Sep 7, 2006
    Location:
    In the velcro closure of America's Hat
    #5
  5. aponsin thread starter macrumors member

    Joined:
    Mar 28, 2009
    #6
    Thanks for the link, but I don't see the same problem as me on that link.
    And what's really bothering me is that I have been using that battery pack for about 1.5 years now without a single problem... And like this it would die on me while I am using it... I don't it seems weird to me...

    I guess I'll try to contact apple.

    Alex
     
  6. MikhailT macrumors 601

    Joined:
    Nov 12, 2007
    #7
    Believe me, stranger things has happened. You may not be able to get replacement for free since I don't think AppleCare covers battery after a year, but that doesn't mean anything. Apple is usually very generous about everything, keep annoying their customer service, apple stores, go to managers blah blah. You'll get it replaced somehow.
     
  7. brop52 macrumors 68000

    brop52

    Joined:
    Feb 26, 2007
    Location:
    Michigan
    #8
    Go to Apple System Profiler and let us know the battery info (Apple Menu-About This Mac-More Info-Power). We are mostly interested in the cycles, whether it says check battery, and the maximum battery capacity.
     
  8. aponsin thread starter macrumors member

    Joined:
    Mar 28, 2009
    #9
    Well the problem is that I cannot have the computer running if the battery is inside... therefore I can get no information whatsoever about the battery cycles, etc.

    Charge Information:
    Charge remaining (mAh): 0
    Fully charged: No
    Charging: No
    Full charge capacity (mAh): 0
    Health Information:
    Cycle count: 0
    Battery Installed: No
    Amperage (mA): 0
    Voltage (mV): 0

    Does not help much :)

    Alex
     
  9. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #10
    Can you check the battery terminals to see if anything may be causing it to short? Do you have warranty? I would get the computer checked out.
     
  10. aponsin thread starter macrumors member

    Joined:
    Mar 28, 2009
    #11
    That's the first thing I checked... but all the contacts looks "perfect". And it's no longer under warranty...

    Alex
     
  11. aponsin thread starter macrumors member

    Joined:
    Mar 28, 2009
    #12
    Very bad news for me :(

    Well as I unfortunately expected it's not the battery that has a problem... it's the macbook...

    I want to an apple certified reseller, and the guys were kind enough to let me run some test on a demo macbook they had over-there.

    As it turns out, my battery is working just fine ! I tried to use it in the demo macbook and indeed no problem.
    Now I tried the demo battery in my macbook, and I was experiencing the exact same problems:
    - impossible to boot with a battery inside (the screen won't even turn on, and no chime, the only thing that tell me the macbook is on is that I hear the bzz bzz initiation of the optical drive and the white light is on)
    - computer works just fine if there is no battery but with magsafe connected
    - if I plugged my battery (or the demo one) in my macbook while running (logged on, etc.) the computer will crash INSTANTLY.
    - if I ever put any battery in and try to boot it (after I remove it) it won't work until I do an SMC reset...

    My warranty has expired... I tried to contact local apple tech support (I am in Hong Kong at the moment), the guys have no idea what is going on... and have no advice for me...
    So I opened a ticket at the US tech support (where I actually bought my macbook), they should call me back sometime... I hope they'll have some options for me :(

    If they don't... I am screwed, because at the moment I can't afford to pay for a new logic board... and it's probably going to cost the same thing as buying a new one...

    :(

    Alex
     
  12. brop52 macrumors 68000

    brop52

    Joined:
    Feb 26, 2007
    Location:
    Michigan
    #13
    Sorry to hear about that. That was the answer we were trying to avoid.
     
  13. aponsin thread starter macrumors member

    Joined:
    Mar 28, 2009
    #14
    Yeah... me too :(
     
  14. laundrmat macrumors newbie

    Joined:
    Jul 26, 2009
    #15
    I'm having the exact same problem with my white MacBook, just over 1 year old. I haven't taken it in yet, but I'm hoping it's the battery, rather than the laptop.

    Any new ideas about this in the past few months?
     
  15. deadtroll macrumors newbie

    Joined:
    Jul 28, 2009
    #16
    Same problem... more info

    I've got exactly the same problem I think... some questions:

    - do you notice that when it crashes, the hard drive is still spinning, and the backlight (if it was on) goes to full brightness?
    - if your cpu load is very low, I find that I can use the computer with the battery in, is this true for you also?

    This is an incredibly frustrating problem.... I can only push my processor if I don't have the battery in, but as soon as you take out the battery, the cpu automatically drops to 1ghz, according to Apple "so that the computer does not draw more power than the ac adaptor can provide"... WTF?! It's an AC ADAPTOR!? Why can't it provide more power than a battery!?!?!?!?!

    ARGH!
     
  16. DevilMayCry, Apr 29, 2016
    Last edited: Apr 29, 2016

    DevilMayCry macrumors newbie

    DevilMayCry

    Joined:
    Jun 16, 2015
    #17
    I'm having the same weird issue on my Macbook Air 11' mid 2011 model, what I did as a workaround was I unplugged my battery (note that I've even DIY changed my battery) ... but the problem persists ... I've drill down the problem to certain extend that is when I'm on battery, it works more stable, but once I plug in my power outlet to recharge it, the issue immediately resurface (grey screen kernel panic screen, restart automatically).
    From my terrible experience I think it could be the I/O board issue (the I/O board were the part which carries the magsafe connector, USB port and audio port on your left hand side) refer https://www.ifixit.com/Guide/MacBook+Air+11-Inch+Mid+2013+I-O+Board+Replacement/16946 ...
     

Share This Page