WEP Password Doesn't Work - Connection Timeout... Round 2

Discussion in 'Mac Basics and Help' started by Vortor, Oct 6, 2010.

  1. Vortor macrumors newbie

    Joined:
    Jun 19, 2010
    #1
    Hi everyone,

    I have been pulling my hair out lately, trying to find a way to restore internet connection on my 27" i7 iMac.

    I know WEP isn't the best choice but that was the only way to make sure all computers worked properly. The technician tried other security protocols but some Windows machines couldn't connect to the internet.

    So, it's WEP or no security protocol at all, which isn't a viable option for obvious reasons.

    My router is a SMC ADSL2 Barricade g (SMC7904WBRA) and before getting the iMac I never got problems with it.

    Everything was fine and dandy until I came home yesterday and noticed the iMac internet connection was down. Every once in a while he does that, so I wasn't too worried.
    The problem is a common one: when he asks for the WEP password and I write it down, all I get is the "Connection timeout" message.

    All other Windows machines are working 100% by the way, which consist of a few laptops and a few desktops. The 27" i7 iMac (v 10.6.4) is the only affected computer.

    I know the password is right, so the problem isn't there.
    In the past, I've managed to get the iMac internet connection to work by changing the channel ID (when inside the router AdminPanel) from 6 to 11 or vice-versa.
    Or turning off and on the router.
    Turning on and off Airport.
    Deleted all the Keychain entries.
    Tried to add a $ in front of the password.
    Deleted com.apple.airport.preferences.plist.

    Unfortunately, none of that seems to be working now and I don't know what to do. :confused:

    Advice? I already spent several hours today on Google trying to find answers but 99% of the stuff I found was outdated, poorly explained or useless.

    Thanks. :apple:
     
  2. jaydentaku macrumors member

    Joined:
    Sep 28, 2010
    Location:
    Durham, UK
    #2
    I think the first problem is, why are your PC systems not playing the game with WPA or WPA2.

    WEP, as you say, really isn't the best choice.

    Personally, I cant abide work arounds.

    So my advice is this, solve your WPA issue first, then get the imac on WPA aswell.

    If a tech walks away from a problem like this, then he/she isn't so great a tech, no offence them them, but get a decent tech to solve this for you.

    I wouldn't dare leave a problem like this unsolved, we would go out of business fairly quick.
     
  3. Vortor thread starter macrumors newbie

    Joined:
    Jun 19, 2010
    #3
    Hi,

    For a moment I had internet connection on my iMac, but the other Windows laptops (one XP and one Windows 7) lost connection.

    A friend of mine advised me to get some MAC addresses and enable MAC filtering. I did that.

    I added the MAC filters. The iMac can no longer connect to the internet, so I was forced to grab an ethernet cable and link my Windows XP laptop to the router, otherwise I couldn't access the router admin page on any of the three machines.

    Currently, both Windows machines have internet connection, while the iMac doesn't (so the situation is the same) which means either the iMAC gets internet connection or the Windows laptops do.

    Only difference is that now, in addition of the WEP protection, I activated MAC filtering.

    Sigh...

    What is better? Using no security protocol (WEP/WPA) while using MAC filters, or just WEP?

    Edit: I just turned off WEP/WPA security and disabled MAC filtering. Still, the iMAC can't connect to the internet, despite seeing the network. As expected, the Windows machines had no trouble connecting.

    Is it possible that the problem is hardware related?
     
  4. Vortor thread starter macrumors newbie

    Joined:
    Jun 19, 2010
    #4
    Two days ago, somehow the internet connection come back. But now, it lost connection again.

    I can't even connect to open networks. Can this be faulty hardware?
     

Share This Page