WEP Password Doesn't Work - Connection Timeout...

Discussion in 'Mac Basics and Help' started by Vortor, Jun 19, 2010.

  1. Vortor macrumors newbie

    Jun 19, 2010
    Hi all,

    Brand new Mac user here. :)

    I already spent a few hours checking old threads and other websites for suggestions, but they didn't help.

    So, this afternoon everything was fine until a few hours ago when the internet connection inexplicably started giving problems. Before that, I was just browsing on the web. I never messed with any network configurations.

    I own an iMac 27" (Mac OS X version: 10.6.3) that keeps asking for a WEP password. I write it down but the only thing I get is a "Connection timeout" message.

    I'm using a SMC router (ADSL 2 Barricade G) by the way.

    I understand WEP isn't the best choice, but the tecnhician said it was the only way to make all three computers have internet access. With WPA, the two Windows laptops had problems conecting.

    I changed the client to "No WEP/ No WAP" and every computer can connect to the internet. However, this isn't the desired solution for obvious reasons.

    On the Mac, I removed the old network settings. I tried the $ (and 0x) trick but it didn't work. I also removed the old network passewords from the Keychain.

    I know the WEP password is right, because I used it on both Windows machines when I changed the client type back to WEP Only.

    Since the SMC router doesn't display the WEP password, I'll download some password recovery software to find it out. I doubt this will work, but I'm running out of options. I'm not a tech guy.

    Hope you can help me out.

  2. Dave Braine macrumors 68040

    Dave Braine

    Mar 19, 2008
    Warrington, UK
    I've been having the same problem with my Intel Mini recently. When waking it would often not reconnect to the router, with the router not even showing in the Airport menulet. This was with my MacBook getting a full signal just 3 feet from the Mini.

    Even when the router did appear in the menulet, it would ask for the password(WPA in my case) and I would get a connection timeout. Going via Network Connection and using the Diagnosis tab it would ask for the password, and sometimes connect, but often it would tell me that the password was wrong. Rebooting would get a connection, but the problem would reappear.

    I tried looking for an Airport .plist to trash, but couldn't find one. In the end I used the Assist tab in Network Connection to re-setup the connection and did everything in Onyx's Automatic section and things seem to be Ok now.
  3. Vortor thread starter macrumors newbie

    Jun 19, 2010
    Don't know what to do.

    What's a plist? And Onyx's Automatic section?

    Not sure if this is revelant, but the Airport Utility is unable to find any wireless devices. This doesn't matter, because I'm using a SMC router, right?

    Edit: I also did this:

    Still no changes. I'm getting the "connection timeout" warning messagen when I try to connect to my home wireless network.

    This means the WEP password is fine and the problem lies somewhere else, right?

    Edit #2: Trashed the whole SystemConfiguration folder. It picked up the network but now when I try to write down the WEP password it says "The password you entered is invalid."

    Decided to restore the folder.

    Edit #3: I'm not sure, but aren't iMac 27" supposed to come with an integrated AirPort Extreme? Isn't something supposed to appear when I use the Airport Utility? Currently, I get a message "Airport utility was unable to find any Airport wireless devices..."and a Rescan button.

    Pressing it doesn't do a thing.

  4. Vortor thread starter macrumors newbie

    Jun 19, 2010
    Problem solved!

    Can't believe it was this easy.

    Just logged in on my router admincp and changed the channel from 6 to 11.


  5. Dave Braine macrumors 68040

    Dave Braine

    Mar 19, 2008
    Warrington, UK
    Number 3 was the .plist I was referring to. I obviously need to look closer. If the problem returns, I'll try a channel change as well. Thanks

Share This Page