Western Digital Hard drive keeps ejecting

Discussion in 'Mac Basics and Help' started by AtrBirkett, Mar 20, 2010.

  1. AtrBirkett macrumors newbie

    AtrBirkett

    Joined:
    May 27, 2009
    Location:
    Here, or there, mainly here though
    #1
    I have had this for a day now, and since I backed up using time machine when I plug it in it ejects within a minuet.

    I have no clue as to why?

    I have not set it to sleep either with the software it came with, or System Preferences.

    Any help?
     
  2. Shadow macrumors 68000

    Shadow

    Joined:
    Feb 17, 2006
    Location:
    Keele, United Kingdom
    #2
    I know this may sound condescending, but is the cable plugged in properly? And the power cord?

    Failing that, either your drive is failing or your port is failing. Two things:
    • If you're using Firewire, the controller WD use is well known for failing - this even happened to me
    • Try tesing the port with other devices. If those fail too, it's the port and you should contact Apple. Otherwise, it's the drive and you should try USB (if using Firewire) and get a new one
     
  3. dbit macrumors regular

    Joined:
    May 2, 2006
    #3
    Does anybody else have any research on this issue? I'm sick of people saying check the plugs, etc. A simple google search will reveal hundreds, maybe thousands of people having WD drives eject themselves on the macintosh platform, but everyone is pointing fingers, and no one is offering answers.

    Anyone find anything out about this issue?
     

Share This Page