Western digital my passport external drive keeps ejecting....

Discussion in 'Mac Accessories' started by nippyjun, Apr 17, 2011.

  1. nippyjun macrumors 65816

    Joined:
    Jul 26, 2007
    #1
    I purchased a new western digital my passport essential external drive.

    It keeps powering down/ejecting on it's own.

    It's the kind that is powered by the USB ports on your computer.

    I formatted it with fat32 but I also tried Mac formatting and it did not matter.

    I'm using it on a late 2008 MacBook pro.

    I tried a different USB cable with no benefit.

    It shuts down at what seems like random intervals.

    Any ideas on what this can be?

    Thanks.
     
  2. nwroberts macrumors member

    Joined:
    Jan 2, 2011
    #2
    It's Western Digital. Enough said. Take it back and get Seagate of any kind.

    And then the IT guy inside of me wants to know if you tried restarting your computer yet?
     
  3. nippyjun thread starter macrumors 65816

    Joined:
    Jul 26, 2007
    #3
    Yup. Multiple restarts.
     
  4. aygie macrumors regular

    Joined:
    Oct 27, 2007
    #4
    Could it be the USB connection on the Hard Drive? I've seen before some portable hard drive connections are very sensitive, try moving the USB cable around a bit and see if ejects it. But as the other guy said take it back and get a new one.
     
  5. nippyjun thread starter macrumors 65816

    Joined:
    Jul 26, 2007
    #5
    I tried a different cable, firmware, format type to no avail.

    I have a new one on order from staples. :eek:
     
  6. nwroberts macrumors member

    Joined:
    Jan 2, 2011
    #6
    Good call, chances are it is just bad. If you get another one that doesn't work, could be a bad firmware on the drives that make it incompatible with a Mac. Have you tried plugging it into a Windows PC?
     
  7. nippyjun thread starter macrumors 65816

    Joined:
    Jul 26, 2007
    #7
    I didn't try on a pc. The new one should arrive soon. It will be interesting to see if it's the drive or the firmware.
     
  8. blevins321 macrumors 68030

    Joined:
    Dec 24, 2010
    Location:
    Winnipeg, MB
    #8
    I, too, had a Western Digital drive that suffered from premature ejection. Never had a problem with internal, only USB. Return before something is lost ;)
     
  9. nippyjun thread starter macrumors 65816

    Joined:
    Jul 26, 2007
  10. aygie macrumors regular

    Joined:
    Oct 27, 2007
    #10
    Create a new user account and see if the drive does the same thing on that account, if it does then it looks like a hardware fault with your machine, if it doesn't then it looks like an OS issue...
     
  11. hotgrom7 macrumors newbie

    Joined:
    Jul 24, 2004
    #11
    annoyed.com

    I have exactly the same problem - just bought a new WD passport 1TB with USB3 and it randomly powers down / unmounts. Could be 5 seconds, could be 10 minutes. I also have this problem with my internal iSight camera, and occasionally with my USB keyboard. Pretty certain that this is a hardware error, but it's annoyingly intermittent. Taken it to the shop a few times and each time the problem magically goes away so the technician can't really see whats going on. What's weird is that I also have a WD 360GB passport (older one) which I've been using for a year with no problems whatsoever. Have tried creating a new user account and the problem persists - lost my startup disk so can't do the reinstall. Thinking of buying Lion but heard it sucks. Otherwise it has to be a repair of USB hardware.
    What should I do??? Doing my head in!

    ----------

    Whoops forgot to mention, I have an iMac 24" running 10.5.8
     
  12. nippyjun thread starter macrumors 65816

    Joined:
    Jul 26, 2007
    #12
    It's not the drive itself as i've had 2 that do the same thing. It's either the firmware or the western digital smartware software.
     
  13. yeungman macrumors newbie

    Joined:
    Sep 28, 2011
    #13
    I have a 640GB USB2 Passport formatted as HFS+ and it works fine for me. It goes to "sleep" after a few minutes of inactivity, but stays mounted. Whenever I need it again, it just wakes up.

    I did, however, remove that smartware crap by booting into an old Windows XP install disk and deleting the passport's entire partition.

    Maybe the firmware on those new USB3 drives are screwy for Macs.
     
  14. Negritude macrumors 6502

    Joined:
    Jul 14, 2011
    #14
    You might try turning off the internal sleep function of the drive. You can do that using the WD SmartWare software.

    I would also uncheck "put hard disk(s) to sleep when possible" in Energy Saver.

    See if that makes a difference.
     
  15. hotgrom7 macrumors newbie

    Joined:
    Jul 24, 2004
    #15
    Tried all that - it's nothing to do with sleep function. It works absolutely fine on my Macbook. It has to be a problem with the USB hub on the iMac. Anyone know how easy this is to fix?
     
  16. bu1hamilton macrumors newbie

    Joined:
    Oct 30, 2011
    #16
    1tb wd passport

    I have (1) 640gb, (2) 500gb wd passport and had no problem with them. just bought a 1tb and it keeps giving me a "can't eject because device is in use" while i'm transferring files from one to another, then finally the 1tb will just eject itself???????...all the hard drives are formatted the same...exfat. any help????
     
  17. KirkWestwood macrumors newbie

    Joined:
    Apr 1, 2012
    #17
    mine is doing the same thing

    Not on my work computer, my iMac or my friends tower, ONLY on my MacPro laptop.

    It is driving me crazy, it unmounts intermittently. There has to be something that can fix this!
     
  18. paul.coman macrumors newbie

    Joined:
    Mar 17, 2012
    #18
    This works >>>

    Do yourself a huge favor and wipe that thing clean! I had the same issue and I used the disk utility option under applications in finder, and wiped it clean. I removed every evidence of WD. Then I uninstalled the application from the computer, restarted and BOOM! It works now.

    The disk utility is located in Finder/ Applications/ Utilities/ Disk Utility. Highlight the Passport. CLick the erase tab. Set on Mac OS Extended (Journaled) and Click Erase.
     
  19. BrandMac macrumors newbie

    Joined:
    Jun 19, 2012
    Location:
    Long Beach, CA
    #19
    Read all posts and this worked

    After reading all the posts concerning this issue with the WD Passport Essential 1TB external drive, which I had the same issues with, as stated above, I simply removed the SmartWare application that I downloaded and everything is working fine now.

    I went through a huge process of calling up Western Digital and having them first send me a new USB cable that was supposed to give me more power at the USB ports. Then, when that didn't fix the problem, a Mac Genius told me to uninstall any security applications that might make the HD quite unexpectedly. They said it could possibly be an OS X problem.

    Well, after uninstalling my security app and still having the same problem, I went ahead and did the one thing I initially wanted to do from the beginning, but didn't because it seemed like a good accessory, I uninstalled and trashed the SmartWare app for the drive, and whala, everything is fine. No random ejections. Happy trails.
     
  20. imsiegfried macrumors newbie

    Joined:
    Jul 2, 2012
    #20
    Hi!

    How do you uninstall the WD Smartware app from the backup Drive?

    I never downloaded or installed the WD Smartware app onto my Mac but it always loads the WD Smartware Virtual Disk Image (is that the correct word?) on my desktop when I attach my Passport.

    When I try to eject the Passport drive I still have the WD software on my desktop that keeps the drive running. I click eject for the WD software and after about 20 minutes it finally "ejects" the software.
    It's driving me nuts.

    I'd love to uninstall the WD software from the drive completely *without* losing the backups I already have. Is that possible? If so, how did you uninstall it?

    Oh! For what it's worth I called Western Digital and they sent me a faster cable too. <grin>.

    I'm a total newbie and afraid to mess with my backup drive without knowing exactly what it is that I'm doing.

    Thank you!
     
  21. sonik25 macrumors newbie

    Joined:
    Feb 17, 2016
    #21
    Found a solution!
    Hey Guys!
    I am macbook user (OSX, El Capitan V.10.11.3.)
    I followed the troubleshooting webpage from WD and it actually worked.
    in the PDF user manual in page 38 they actually clarified how to create a partition for your External drive.
    Go to http://support.wd.com and refer to Knowledge Base Answer ID 3865 for information about reformatting the drive.Then choose instruction for El Capitan. Step by step you'll see how you should go to Disk Utility and choose Mys Passport drive and the choose partition, if this option was not bold you should erase the drive. I tried erasing but it didn't work and showed an error in every attempt. So I followed this troubleshooting tip: I safe boot my mac (restart it and after you hear the famous voice, hold the shift key until you see the apple logo, then release it. When your safe boot desktop came up disconnect the wireless or ethernet and go through the same disk utility to find your external hard driver. At this time I could erase my driver and it was successful. So the partition option turned up bold and I started partitioning. In the partition box you need to choose the OS X Extended (Journaled) format. Voila, its fixed! You can restart and go to your normal operation system and use your formatted WD drive.
     

    Attached Files:

  22. LiveM macrumors 6502a

    LiveM

    Joined:
    Oct 30, 2015
    #22
    This happens with Seagate drives, too. It's software, not hardware.

    Regarding errors erasing the disk to reformat, select the topmost drive in the hierarchy for that hard drive unit, not the one under it.
     
  23. al881, May 2, 2016
    Last edited: May 2, 2016

    al881 macrumors newbie

    Joined:
    May 2, 2016
    #23
    Western Digital installed software named WD Drive Utilities
    Launch the software, select "Sleep Timer". Turn it off.
    Should work now. El Capitan 10.11.4

    Never mind, drive still ejects
     
  24. KK108 macrumors newbie

    Joined:
    Aug 9, 2016
    #24
    I've done everything suggested on this thread so far: uninstalled Smartware and deleted the app, deleted all the WD 'extras' that came on the passport drive (security and drive utilities), used disc utility to erase then partition. Still getting the intermittent eject messages. I was going to go get a Seagate (my old seagate has never had problems) but you say here that it happens with Seagate, too. Any other suggestions? I have a 2008 MacBook Pro.

    Thanks!
     
  25. LiveM macrumors 6502a

    LiveM

    Joined:
    Oct 30, 2015
    #25
    Seems like a gamble whatever you buy. Thankfully my Lacie 8TB Porche Design for Mac is fine (Time Machine) as well as my Seagate 4TB for Windows (reformatted) as those things are not cheap.
     

Share This Page