Western Digital MyBook 1TB not functioning properly

Discussion in 'Mac Basics and Help' started by markmansion, Aug 17, 2009.

  1. markmansion macrumors newbie

    Joined:
    Aug 17, 2009
    #1
    I bought a Western Digital MyBook 1TB external hard drive a while ago and it was working fine with my Powerbook G4 running Tiger. But when I wanted to have it connected to my Intel Mac Mini running Leopard it always has a few problems.

    1. It randomly disconnects and the message for external hd not ejected properly.

    2. When I try to copy a large file to it like a 500MB file it goes so slow and when it looks like it will finish I get the error code -36

    3. After all the problems 1 and 2 it won't eject and when I try to unmount it from disk utility it says it can not be unmounted.

    I have tried to reformat the drive for mac with the extended journaled and partitioning and erasing with boot disk procedures. Still nothing seems to work.

    I don't know if this matters but I bought it at a Walmart and it wasn't mac formatted. Would I have to specifically buy a mac formatted external hd in order for it to work in leopard? Or can I some how format this to work properly on my computer. I also have an Iomega 120GB drive that I bought a few years ago from apple.com and it works flawlessly on both my PB and MM.

    I just have a hard time believing that only certain hds will work for an intel mac running leopard. I thought all hds were the same and could be formatted to run on any system.

    If anyone could help me out I would greatly appreciate it.
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    More or less. I haven't switched a drive between Leopard & Tiger machines in a while but I don't recall any major problems back when I did that. Perhaps you could call WD support?
     
  3. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #3
    They are. The behaviour you describe is not normal.

    Have you tried another USB cable?
     

Share This Page