Western Digital MyBook - can't free up space

Discussion in 'Mac Accessories' started by RUFiO795, Oct 28, 2009.

  1. RUFiO795 macrumors member

    Joined:
    Aug 9, 2007
    #1
    I have a 500gb WD MyBook external hard drive...

    I only have about 150 gigs on it, but it tells me that there are only 113 gigs left, which I have figured out is because it does not seem to actually free up space when I delete files from it. So, essentially, every time I add a file, the space that that file fills is filled permanently, even if I later delete the file.

    The only solution I've been able to find from browsing forums and googling is to partition my hard drive as Mac OS X Journaled (extended), but it is already partition thus. I don't have the space on my internal hard drive to move everything onto it while I completely reformat the external....

    Any ideas?
     
  2. Flipstar macrumors member

    Joined:
    Jun 21, 2007
    #2
    Empty the trash?
     
  3. RUFiO795 thread starter macrumors member

    Joined:
    Aug 9, 2007
    #3
    Ah. Good call, although now I realize what the problem has been...

    I can't delete what I've dragged into the trash from the external! It looks for files for a while, allegedly "preparing to empty the trash" and eventually gets stuck on a relatively huge number of files (350,000+). From browsing the forums, it looks like this is because of my Time Machine backups in the trashcan...

    ...it also doesn't look like anyone has really figured out a solution. I've tried the option-empty method, don't know if fooling around with Terminal is a good idea (and can't figure out how to enable the root user anyway), and am otherwise out of ideas. It's very frustrating that Apple designed backups that can't be destroyed.

    Any new breakthroughs on this topic? I'd love to not have 300 gigs of my external hard drive taken up by backups that I'm trying to delete.
     
  4. Flipstar macrumors member

    Joined:
    Jun 21, 2007
    #4
    Well, first thing to do is make sure that the drive that you're "emptying the trash" on is connected.

    There's terminal code you can use to force empty the trash with (or use Onyx).. not sure if it'll work in your situation
     
  5. RUFiO795 thread starter macrumors member

    Joined:
    Aug 9, 2007
    #5
    The drive I'm emptying the trash for is definitely connected - the files that I'm attempting to delete (which include the problematic Time Machine backup-in-progress file) don't even show up in the Trash unless the drive is connected.

    What is the terminal code I can use to force empty the trash? I've tried the hold-control-while-emptying method, and that didn't do anything as far as I could tell. I have no experience with Terminal, so any kind of basic instructions as to how to use it to force empty would be appreciated. Thanks-
     

Share This Page