Western Digital Passport Drive Not Working

Discussion in 'MacBook Pro' started by Paulg2uk, Mar 15, 2013.

  1. Paulg2uk macrumors regular

    Joined:
    Jun 15, 2008
    #1
    Hey guys,

    Need a bit of advice I recently bought a new retina MBP and always use an external drive to store my iTunes library on. I have a western digital my passport drive 1tb which when plugged into any of the usb ports on the mbp doesn't show up on my desktop. i can see the white activity light come on the drive itself but it remains constant and doesn't do anything.

    If I plug a powered usb hub in to my mbp and then plug the drive into that it works. I'm guessing that the mbp doesn't have enough power via its ports to make the drive work?

    I've tried reformatting the drive but it doesn't make any difference.

    Can any one help?

    Many Thanks

    Paul
     
  2. Ccrew macrumors 68020

    Joined:
    Feb 28, 2011
    #2
    Reformatted to what? HFS+ on another Mac would be the preferred choice.

    Can Disc Utility see the drive?

    And the stupid question (sorry, have to ask it) Do you have Finder Preferences set to show external discs on the desktop? It's disabled by default.

    I own multiple WD drives, I have no issues seeing any on retina MacBooks.
     
  3. Paulg2uk thread starter macrumors regular

    Joined:
    Jun 15, 2008
    #3
    I tried formatting to both mac os extended and MS DOS. It's worked before on my old macbook on those formats.

    Disk utility can't see the drive it doesn't appear or on the desktop either. I do have the external disks option selected via finder.

    Very strange I could reformat via my imac and see what happens. If there was a problem via the formatting surely it wouldn't appear when plugged into the external powered hub?

    Cheers

    Paul

     

Share This Page