western digital passport (ehd) stopped working suddenly - not recognized

Discussion in 'Mac Accessories' started by tkjazzer, Jan 5, 2009.

  1. tkjazzer macrumors 6502

    Joined:
    Nov 30, 2004
    #1
    Hello,

    I have a western digital passport ehd with HFS+ formattnig on my mbp.

    It was working fine for months. I tried always to properly eject it, but occasionally I would meess up and improperly eject if like the HD fell off my lap and the cord came undone or something.

    Anyway, I think I really got myself in a pickle now.

    I was either downloading something and then forcequit which caused it, or restarted finder, or something where now my EHD is not even recognized.

    when plugged in to the usb it looks like it is recognized on system profiler as "vendor-specific"

    on disk utility it was recognized once and I didn't take the opportunity to try and repair, but instead tried to save data... bad move - now it doesn't even pick up on disk utility - just shows my internal hd.

    I tried resetting the PRAM - i don't know exactly what that does but I read I should try that somewhere.

    I tried starting in safe mode... didn't do much.

    What other options do I have?

    Thank you!
     
  2. brand macrumors 601

    brand

    Joined:
    Oct 3, 2006
    Location:
    127.0.0.1
    #2
    That could have something to do with it.
     
  3. tkjazzer thread starter macrumors 6502

    Joined:
    Nov 30, 2004
    #3
    no, probably not. it is spinning just fine, always landed on thick, thick carpet or on to my bag which gives it a huge impuslse (j) so it is not likely due to physcial dmg.

    if disconnecting at odd times causes a data error, then yes maybe it is.
     
  4. tkjazzer thread starter macrumors 6502

    Joined:
    Nov 30, 2004
    #4
    ever heard of removing the casing and trying to slave the external hd directly to a motherboard?

    idk how that works, but it might be worth a shot since I don't feel like paying 10k dollars to retreive info.
     
  5. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #5
    Probably. Running hard drives are fairly sensitive to physical shock.

    Not an option on a laptop. You could try buying a new 2.5" enclosure, though.

    You don't have a backup, I take it?
     
  6. tkjazzer thread starter macrumors 6502

    Joined:
    Nov 30, 2004
    #6

    it's funny though because after I dropped it still worked. It started acting funny when firefox jammed when trying to do a download where firefox was going to ask me where do I want the file and the last file downloaded was put in the download folder was on the EHD. after that it started jamming up and not wanting to eject. I don't know what that "symptom" points towards...

    well, i used the HD mainly for internet downloads because ididn't want them going straight to my native HD. i also put a computer game on it and some videos. i can replace most things - just not the music - i recently transfered my itunes library to it... that will stink becaus eit will wipe my iphone when I update it to 2.2... sigh...
     
  7. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #7
    If it were a software problem, it would show up in Disk Utility, even if it were corrupted.

    Try:

    1) Check the cables, outside and inside the enclosure.
    2) Try a new enclosure.
    3) Bin it and buy a new drive to go with your new enclosure.

    There are software solutions to allow you to recover music from an iPod, you know.
     
  8. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #8
    Senuti will get your music off your iPod/iPhone for you.
     
  9. wizzracer macrumors 6502

    wizzracer

    Joined:
    Sep 17, 2007
    Location:
    Dallas, Texas
    #9
    If you can see it mounted use the WD disk recovery tool that came with it.
     

Share This Page