Western Digital portable hard drive and Time Machine problem

Discussion in 'MacBook Pro' started by rsreekantan, Sep 21, 2009.

  1. rsreekantan macrumors newbie

    Joined:
    Sep 21, 2009
    #1
    Hi

    I have been using a Western Digital Passport drive for my Time Machine backups and till yesterday it was working fine. Yesterday it suddenly failed while I was doing an update - the update failed - and now my MBP ( with Leopard ) doesnt recognize the disk any more.

    It seems to be supplying power to the drive as the light on the drive comes on. I must add that I used the same cable for my phone and could transfer data to my Nokia phone, but now it says - `memory card in use by another device'.

    I have tried all kinds of things to make it work - including downloading USB prober - which didnt work as the current version is for Snow Leopard.... and using AppleJacks to clean up stuff.

    I tried other hard drives on the same USB slot and they seem to work. So does anyone have a solution to my problem ? My suspicion lies with the cable - the USB to mini USB converter cable - Could something have happened to the cable which would cause this ( nothing fell but its plausible that I might have unplugged it without ejecting properly ).

    Ramesh
     
  2. SpaceKitty macrumors 68040

    SpaceKitty

    Joined:
    Nov 9, 2008
    Location:
    Fort Collins Colorado
    #2
    I had a problem using a 250GB passport as well. It would power up and then the light would get bright every few seconds and it would make a clicking noise every few seconds as well. I think it may have something to do with the power on USB ports.

    I ended up opening the enclosure and putting the drive in a laptop. It's still in there and works with no problems.

    Do you have another computer to try plugging it into?
     

Share This Page