Western Digital release fix for data loss on external drives

Discussion in 'OS X Mavericks (10.9)' started by TV Cameraman, Nov 26, 2013.

Thread Status:
Not open for further replies.
  1. TV Cameraman macrumors member

    Joined:
    Feb 3, 2008
    Location:
    Los Angeles, CA
    #1
  2. TV Cameraman thread starter macrumors member

    Joined:
    Feb 3, 2008
    Location:
    Los Angeles, CA
    #2
    Ha! I beat the Front Page of Macrumors by 1 minute! I had sent it to tips@macrumors right before I posted here. :)

    WD released the updates yesterday. Kind of strange that no one noticed until today... they had so much bad press about this, I figured they would do an all-out PR assault with the news of this fix.

    Hope it prevents more data loss from happening. I was lucky and did not lose any data on my and of my 7 WD external drives. I uninstalled the old software with the uninstaller they had posted on their website for a while and now I'm unsure if should install this new software at all. Does the new software have a fix built in? Or was the fix removing the software to begin with? I still haven't plugged my externals back in...
     
  3. amoergosum macrumors 6502

    Joined:
    Oct 20, 2008
    #3
    I would never ever install software from WD again.
     
  4. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #4
    I never install vendor's software at all if I can avoid it.
     
Thread Status:
Not open for further replies.

Share This Page