What AEBS issue might cause long connection lag on some sites?

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Makosuke, Nov 28, 2009.

  1. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #1
    This is half a "what I did to fix it in case somebody else Googles in with the same problem" and half "Any idea what's going on here?"

    Setup: AT&T DSL modem wired to AEBS (first gigabit model), in turn connected wirelessly to a MBP and several other devices, and hardwired to a mini and G5 tower. WPA2 personal, MAC access control.

    Here's the bizarre symptom: A few websites, apparently at random, take in the 30-60 second range to respond to a request. It was usually just one or two very specific sites, which seemed to change periodically; it was subtle enough that I thought it was just the sites lagging until I realized it was fine from everywhere else in my area.

    When several sites I frequent developed the problem simultaneously about a week ago, I started experimenting to try and nail it down.

    Had nothing to do with DNS, since it remained the same after manually switching to OpenDNS. Wasn't plugin- or Javascript-related, since the lag even happens when trying to load a single image direct from its URL. The problem presented on all three Macs on my network, regardless of whether they'd ever accessed that site before or were connected wirelessly or wired, so it wasn't a system-level caching problem. Same behavior for every browser. Not a general network problem, since everything else, both external and computer-to-computer, ran fine and at full speed.

    The problem does NOT happen if I bypass the AEBS and plug directly into the DSL modem. Also, particularly strangely, my iPod Touch did NOT suffer the same problem, even when a MBP connected via the same 802.11g is demonstrating the lag at the exact same moment.

    Power cycling the AEBS and modem doesn't help.

    So, I randomly started changing settings on the AEBS until the domains started responding properly again. So far as I can tell, what made the difference was switching IPv6 from "Tunnel" to "Link-local only". It hasn't been long enough to be sure if that actually made the difference, or if it was a coincidence/placebo.

    I know my way around a network in general terms, but nothing about IPv6 or low-enough level to understand what that setting does. Any idea why, or if, this was the setting that fixed it? And/or guesses as to what's going on with my AEBS?
     
  2. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #2
    DNS is returning both IPv6 and IPv4 addresses for those troublesome websites.

    The Airport Extreme is configured by default to try and communicate with IPv6 hosts via IPv4 to IPv6 proxies on the Internet (via that 'tunnel' you saw). The problem is that some of these proxies are less than perfect.

    It's my opinion that while this behavior is the right thing to do someday, Apple was a little optimistic in turning it on now.

    A.
     
  3. Makosuke thread starter macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #3
    Thank you--helpful information for someone who prefers to know why a fix worked.

    I assume the reason the Touch was fine is because the iPhone OS has no support for IPv6 currently (or so Google tells me), so it just sidestepped the issue entirely.
     

Share This Page