What am I doing wrong with Sim Free?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cheerwine, Nov 28, 2007.

  1. cheerwine macrumors newbie

    Joined:
    Nov 28, 2007
    #1
    I keep getting the message "unlock failed error baseband communications". I've downgraded and done all of that jazz that they've told me to do. Is there anyone who can explain to me what it is I'm doing wrong here? It's getting to the point where I'm spending more money trying to hack it than if I had just went with at&t (not really but you get what I'm saying). Anyone out there?
     
  2. polishmacuser macrumors 6502a

    polishmacuser

    Joined:
    Jan 17, 2007
    Location:
    Los Angeles
    #2
    by any chance did you unlock with anysim or iunlock. If yes just revirginize the phone you can use idemocracy or go to iphone elite dev team to get it. Plus you have to remove your sim card while unlocking lol. To put it in short terms revirginize and it should be fine unless you have a brand new iphone with 1.1.2 installed already.
     
  3. esalome macrumors newbie

    Joined:
    Dec 20, 2007
    Location:
    Buenos Aires
    #3
    cheerwine,
    I got the same problem (native 1.1.1 unlocked with SIMFREE V1.7 used without any problems for the past 2 months). Yesterady downgraded from 1.1.2 to 1.0.2 (for very stupid reasons I should say) then virginized (using Iunlock.no) upgraded to 1.1.1, unlocked with *#307*...... jailbreak.com.

    BUT somehow the SIM got locked (dind't happened while downgraded and running 1.0.2), I re-installed SIMFREE V1.8 and got the "BASEBAND COMMNICATION EEROR". please any ideas?

    (Version 1.1.1 (3A109a), Modem Firmware 04.01.13_G)
     
  4. piratekid macrumors newbie

    Joined:
    Dec 27, 2007
    #4
    Firmware 1.1.2 (04.02.13)

    I've been trying to unlock my iphone by downgrading from 1.1.2 to 1.1.1.
    But the same version stills coming up (04.02.13). Anyway in the version says 1.1.1.

    Virginizer is not working, and simfree application is not unlocking the phone.
    Is it is true that if you got a phone with firmware 1.1.2 from factory is impossible to unlock it and use it?
     
  5. polishmacuser macrumors 6502a

    polishmacuser

    Joined:
    Jan 17, 2007
    Location:
    Los Angeles
    #5
    i know you have to downgrade the baseband revirginize it restore it to 1.02 then jailbreak again and run the unlock i had the same problem with one of my friends phone and it worked once revirginzed just restore and you should be fine :)
     
  6. piratekid macrumors newbie

    Joined:
    Dec 27, 2007
    #6
    Just to clarify....

    I've been reading a lot of the impossibility on unlocking the SIM from iPhones that got 1.1.2 OTB with baseband 04.02.13_G. (in serial # the week of production indicates week 46)

    So basically the solution you are providing is:
    1. Downgrade from 1.1.2 to 1.0.2
    2. Virginize it (downgrade baseband)
    3. jailbreak it
    4. Run Anysim application in order to unlock the SIM.

    Is this the process that you tried and worked with your friend?

    Maybe it's a dumb question, but I have fear on leaving the iPhone with any irreversible damage that can't be fixed later.

    I appreciate your supoort polishmacuser.
    Thanks in advance.
     

Share This Page