What am I doing wrong?

Discussion in 'Apple TV and Home Theater' started by SD-B, Jan 13, 2013.

  1. SD-B macrumors 6502


    Apr 1, 2009
    60" HDTV
    Apple 3 so obviously not jailbroken (unfortunately)
    MacBook Pro 10.7.5

    i have downloaded the new Lion but am as of yet to set it up i have been so busy but will do so in a day or two so using Snow Leopard at the moment

    I just set up my apple TV for the first time and have networked it home shared it etc.

    Now, correct me if i am wrong but should I not be able to simply open up iTunes on my Macbook Pro and with a few films I have in mp4 format which are in the library in iTurns be able to watch them on my HDTV?

    iF SO, HOW?
    I Keep seeing a window that shows me lots of tabs for computer, settings, tube, hockey or something and several others i am unfamiliar with.

    But how do I get my films on my mac in my iTunes to play on the screen?

    Or must i do it through my iPhone instead?

    I am a bit confused and need your help, thanks ;-)
  2. wharzhee macrumors 6502

    Apr 27, 2010
    er. i dont know if this answers ur question.

    1. Run the iTunes app on ur Mac.
    2. Enable Home Sharing on ur iTunes(Mac). [associated with ur AppleID]
    See the options on the top left (menu) corner.
    File>Home Sharing>"Turn on Home Sharing"
    3. Switch on Apple TV
    4. Enable Home Sharing on Apple TV. [associated with ur AppleID]
    See setting options on ATV.
    Settings>Computers>"Turn on Home Sharing"
    5. On ur ATV: Go to "computer" icon

    Ta Da! Your iTunes(Mac) library is now available on ur ATV
  3. HazyCloud macrumors 68030


    Jun 30, 2010
    I recommend doing what wharzee said for future use, but if you want to just AirPlay a video to your Apple TV, you have 2 options.

    1. Just tell iTunes to AirPlay to your Apple TV. (1st pic)
    2. Once a video is playing, just hit the AirPlay icon on the video and select your Apple TV.

    (Disregard the checkerboard in the second pic. That's actually a movie playing, but apparently Apple disables that when taking a screenshot.)

    Attached Files:

  4. ybz90 macrumors 6502a


    Jul 10, 2009
    It's disabled for copyright/DRM reasons.
  5. HazyCloud macrumors 68030


    Jun 30, 2010
    That's what I figured, but it's not same for iOS which is a bit weird.
  6. SD-B thread starter macrumors 6502


    Apr 1, 2009

Share This Page