What are these pop-ups and how do i ditch them?

Discussion in 'Mac Basics and Help' started by mikebatho, Dec 16, 2018.

  1. mikebatho macrumors 6502a

    Joined:
    Jun 1, 2004
    Location:
    Greater Manchester UK
    #1
    When I'm in Chrome, When I start up my imac, I get a bunch of these little pop-up ad windows in the top right corner. Each has an X but when I click it to close, another pops up and I have to keep going, sometimes through dozens of the little b*#tards.

    How to I switch them off, disable them, whatever?

    I can't seem to attach a pic, but the ads/windows 4" wide 1" tall, large blue A Applications icon to the left, ad title eg 'MacKeeper is ready to install', an X and a cog, which when clicked pulls up a save/block list, but i don't want to have to block each window once it's appeared, i want to disable that function.

    Thanks.
     
  2. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #2
    Download, install, and run Malwarebytes for Mac: https://www.malwarebytes.com/mac/
    The free version will do what you need.
     
  3. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #3
    Those are notifications....and yes, MacKeeper is essentially malware that you need to uninstall. Good write up here. Hopefully still current info.
     
  4. mikebatho thread starter macrumors 6502a

    Joined:
    Jun 1, 2004
    Location:
    Greater Manchester UK
    #4
    Yeah but i don't actually have MacKeeper installed, that was just an example. Another of these little windows says "Chat with the sultriest Slavic singles"
    --- Post Merged, Dec 16, 2018 ---
    It won't let me install that on Mavericks

    .... trying a legacy version
    --- Post Merged, Dec 16, 2018 ---
    Well I installed that, ran it, restarted and so far so good. I thought it was something that came with a Chrome browser.... THANKS
     
  5. mikebatho thread starter macrumors 6502a

    Joined:
    Jun 1, 2004
    Location:
    Greater Manchester UK
    #5
    Dammit they're back. Full set, eg text PETER JONES WAS STUNNED! text below: something about torrents
     
  6. Fishrrman macrumors Pentium

    Fishrrman

    Joined:
    Feb 20, 2009
    #6
    My suggestions:

    1. STOP using Chrome. Use something else.

    2. Download "MalwareBytes" and run it. The download is free and YOU DO NOT HAVE TO PAY TO UPGRADE IT (regardless of the "prompts"). It will run FOREVER "in free mode".
     
  7. Mr_Brightside_@ macrumors 68030

    Mr_Brightside_@

    Joined:
    Sep 23, 2005
    Location:
    Toronto
    #7
    Why?
     
  8. Lunder89 macrumors 6502

    Lunder89

    Joined:
    Oct 16, 2014
    Location:
    Denmark
    #8
    No need to stop using Chrome, at least not if you don't want to ;). Just need to disable Google Chromes notification system. Since they insist on using their own, and not the one built into macOS.

    Now, I am translating as best as I can from a danish system, so the items you are looking for might not be translated correct. So you might need to hunt down the settings buttons.
    1. Open af Chrome window
    2. Click the "Chrome" menu in the menubar and select "Preferences"
    3. Scroll to the bottom and reveal the advanced settings
    4. In the first group "Security and privacy" look for something like "Settings for content", on my system it is second to last
    5. Here all the settings have icons, look for the BELL icon, on my system it was right under "Microphone"
    6. The blue slider in the top, click it, to turn the notifications off
    That should deal with your problem
     

Share This Page