what causes airport to self assign an IP?

Discussion in 'Mac Basics and Help' started by Draddy, Nov 4, 2007.

  1. Draddy macrumors regular

    Joined:
    Mar 16, 2007
    #1
    So I have a constant problem where my macbook pro will not connect to a network... it will join it, but the it goes to "self-assigned IP"

    this happened this weekend for the entire weekend at my parents house, and eventually we just gave up and went and bought a new netgear rangemax wireless router..

    but now I'm back at my place, with a linksys router, and I cannot join that network... I have to get on my neighbors dlink router in order to get to the internet (it a a condo complex, so we are all on the same internet, just different routers)...

    what is the problem that it will assign itself an IP?
     
  2. CanadaRAM macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #2
    A machine self assigns an IP address when it is set to DHCP (meaning - "get an address from the router") but the router is unavailable or it doesn't respond to the DHCP request.

    Since you are getting an address from your neighbor (obviously without security), then that means there's nothing wrong with your machine. Probably, you don't have the router set up correctly, or you have set security on the router that the Mac can deal with.

    IIRC some routers do not work with Apple Airport machines when they are set to WEP - you have to use WPA.

    Test your machine on the router by Ethernet cable. If it works there, then the problem is with your wireless setup.
     
  3. benlee macrumors 65816

    benlee

    Joined:
    Mar 4, 2007
    #3
    Like CanadaRam said it is not something wrong with your computer. Make sure you are typing in the correct password to join the network and that you are set to the right security option (WPA, WEP). If that doesn't work or you know you have the password correct, I would try reseting the router, or calling your service provider.
     
  4. Draddy thread starter macrumors regular

    Joined:
    Mar 16, 2007
    #4
    thanks!

    but the thing is, is that it's random... I haven't touched the thing... it will work for most of the day, then for like an hour it cuts off and won't assign an address.

    With both this linksys, and the belkin I had at my parents house... eithernet works, and i know for a fact it is setup to run DHCP correctly, i've restored factory settings and started from scratch even...

    now another random thing that you might be able to help with.....with the eithernet jack that the router is plugged into, I can get a DHCP address... and all my neighbors eithernet jacks work correctly,

    but the one in my room also defaults to self assigned IP, and has NEVER worked in the past year......my roommate said that before I moved in, it worked...what would be the cause of this?
     

Share This Page