what causes Wi-Fi to be displayed?

Discussion in 'iPhone' started by ghanwani, Jul 25, 2016.

  1. ghanwani macrumors 6502a

    Joined:
    Dec 8, 2008
    #1
    I recently got an SE and enabled WiFi calling in the settings.

    What I'm finding puzzling is that the "Wi-Fi" that appears next to AT&T on the top bar keeps appearing/disappearing even while I'm sitting in the same place at home. Is there a reason for this? I've seen the phone with and without Wi-Fi with both 2 and 3 bars (dots) of service.

    Is this normal?

    Thanks.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Yes.
    That's how it behaves with AT&T.
    It comes and goes depending on the carrier signal.
    Not a big fan the way they implemented it. You could turn on airplane mode and then enable wifi and it will stay on wifi calling.
     
  3. ghanwani thread starter macrumors 6502a

    Joined:
    Dec 8, 2008
    #3
    Thanks. I see it come and go even with both 2 dots and 3 dots. In other words, it doesn't look it's related to the signal strength as seen by the dots. Is there some other measure that AT&T is working with?
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    I hear you.
    It doesn't make much sense the way it switches from wifi calling to regular carrier connection.
    It probably takes a toll on battery life too.
    I use to sit right next to my router and it would prioritize 2 dots of signal in my basement instead of wifi calling.
     
  5. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #5
    Probably using an actual dB value (or range of values) for the signal.

    http://www.ubersignal.com/field-test-mode
    --- Post Merged, Jul 25, 2016 ---
    Yeah, I wish that at least once it connected it wouldn't disconnect until Wi-Fi was no longer available (or good enough for Wi-Fi calling).
     
  6. ghanwani thread starter macrumors 6502a

    Joined:
    Dec 8, 2008
    #6
    Thanks. At least it's good to know that it's normal.
     
  7. gcipolletti macrumors newbie

    Joined:
    Aug 2, 2016
    #7
    I cannot get wifi calling to work in airplane mode. I enable wifi calling, get on network, go in iarplane mode, turn on wifi, nothing...
     
  8. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #8
    Does Wi-Fi calling work in general?
     
  9. ghanwani thread starter macrumors 6502a

    Joined:
    Dec 8, 2008
    #9
    What phone do you have and who is your carrier? Not all carriers support Wi-Fi calling and not all devices will support Wi-Fi calling even if the carrier in question does. For example, iPhone 5s supports WiFi calling on T-Mobile but not AT&T. One would need an iPhone 6/6S/SE to get Wi-Fi calling to work with AT&T. Now if those are both supported, you need to enable WiFi calling on the phone: Settings -> Phone -> Wi-Fi Calling -> ON.

    Once all of the above has been verified, if it still doesn't work, you may need to call your carrier to get it enabled. For some reason when I bought my first SE (which I ended up returning), I needed to call AT&T to get this enabled. Perhaps that did it for my SIM, because, after I got my second SE, I didn't need to call in to get it enabled.
     
  10. Mlrollin91 macrumors G4

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #10
    If AT&T is your carrier, when you switch to Airplane mode and turn WiFi on, it can take up to 3 minutes for AT&T WiFi to kick in. AT&T WiFi calling is very slow to activate.
     
  11. gcipolletti macrumors newbie

    Joined:
    Aug 2, 2016
    #11
    I have an iPhone 6. WiFi calling is "on" and I have seen the status bar become ATT WIFI. Problem is with 1 bar non LTE connection the connection is iffy at best but the phone won't switch over due to ATT's implementation, which favors cellular. I assume that's so they can still charge minutes for those few people not on an unlimited plan?
    Anyway, when I try the airplane mode trick the wifi calling never appeared in my top bar even after an hour, and when I try to make a call the phone prompts with "turn off airplane mode to make a call". very frustrating!
     
  12. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #12
    They might have disabled it lately.
    I remember months ago when I was still with AT&T once I put it on airplane mode and wifi turned on it would connect and use wifi calling right away.
    Not sure why they would do that to their customers.
    It's very annoying to say the least.
     
  13. Doth macrumors member

    Doth

    Joined:
    Nov 25, 2011
    #13
    Are there any disadvantages to turning Wifi Calling on and enabling other devices? I live in the USA and use AT&T with an iPhone 6s Plus and iPad Air2 and a 13 MBPr.
     
  14. Mlrollin91 macrumors G4

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #14
    The only 'disadvantage' that I have is that when you answer a call on one device, all your other devices will get a missed call notification even though the call was not really missed. Just a bug that will hopefully be fixed in the future. Other than that, I see many more advantages. Doesn't use minutes on my AT&T plan, can answer a call on any device, no matter where I am and my devices are connected to WiFi, increased sound quality and increased battery life in low service areas.
     
  15. ghanwani thread starter macrumors 6502a

    Joined:
    Dec 8, 2008
    #15
    I'm seeing similar inconsistencies. Last night, for example, I had the phone in airplane mode and WiFi calling was enabled. When I checked first thing this morning, the phone was in airplane mode with no WiFi calling.

    Yesterday I was at a store and connected to their WiFi, but WiFi calling just would not get enabled even though signal strength was 1 dot. I put the phone in airplane mode, but even then it kept switching between WiFi calling and no WiFi calling.

    Is this an AT&T specific thing, or is this a problem with T-Mobile as well?
     
  16. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #16
    Nope.
    Just an AT&T issue.
    It's not an Apple bug or problem that effects every carrier with wifi calling.
     
  17. rzc16512 macrumors regular

    Joined:
    Jun 3, 2015
    #17
    Agreed. Was super annoying. I thought t might possibly have been my router (AC time capsule) but since I got sprint it's stayed on the whole time but God knows I need it with sprint lol
     

Share This Page