What DID effect my 4S battery life!

Discussion in 'iPhone' started by Stealthipad, Oct 21, 2011.

  1. Stealthipad macrumors 68040

    Stealthipad

    Joined:
    Apr 30, 2010
    #1
    My 4S has been coming home with 50 to 60% battery at the end of the day from the first day I got it on the 14th.

    Purchased at metal Element Vapor Pro in Black anodized with the carbon fiber cover for the back. The minute I put it on I noticeed a two bar drop in RF. Where I would always get 3-4 bars I am all of a sudden getting 1-2 bars and even seeing the occasion dreaded "E" for EDGE! :(

    At the end of the day instead of having 50-60%, I have only 20%! Same software and iPhone services running, the only difference is the lack of RF due to the Vapor Pro and CF back cover.

    I removed the Vapor when I took it off the charger this am and the battery consumption is looking to be back to normal as I am at 80% after removing it from the charger at 4am. What a huge difference.:eek:

    I do not thing this is everyone problem but I was shocked to see the difference in battery use by killing the RF. I am back to being happy with the battery:)
     
  2. Givmeabrek macrumors 68030

    Givmeabrek

    Joined:
    Apr 20, 2009
    Location:
    NY
    #2
    No surprise. Covering the antenna with metal may not be the smartest thing to do.... :cool:
     
  3. Stealthipad thread starter macrumors 68040

    Stealthipad

    Joined:
    Apr 30, 2010
    #3
    I agree! Their ads are somewhat missleading as they claim it gets rid of the "antenna death grip syndrome"

    I loved the vapor pro but not enough to sacrifice RF.

    Back to the Case Mate barely there.
     
  4. greenlander macrumors member

    Joined:
    Jun 14, 2007
    #4
    Not that it relates specifically to your discovered problem, but I'm starting to wonder if I'm the only one not having issues with the 4S battery.

    People complaining everywhere, but mine has been fine. Just about what I'm used to with the 4.
     
  5. Stealthipad thread starter macrumors 68040

    Stealthipad

    Joined:
    Apr 30, 2010
    #5
    I have no complaints at all as it is giving me about the same service I got from my iPhone 4 and am VERY happy with the performance of the phone in general!
     
  6. TheBigKing macrumors 65816

    TheBigKing

    Joined:
    Jul 27, 2010
    Location:
    PR
    #6
    It's not the case it's the carbon fiber stiker that affect the signal i have the pro never have signal problem rigth now i have the comp on the 4s and 0 problems two
     
  7. smagdy macrumors regular

    Joined:
    Jan 31, 2008
    Location:
    Sweden
    #7
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    Which pro do you have.. Any link please?
     
  8. Stealthipad thread starter macrumors 68040

    Stealthipad

    Joined:
    Apr 30, 2010
    #8

Share This Page