What does the iPhone need Data network with SMS messages?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by aygie, Mar 13, 2010.

  1. aygie macrumors regular

    Oct 27, 2007
    I've had this issue since 3.1.2, everytime (and I mean every single time!) I open my SMS's I get the message

    Now from what I know this is basically telling me I do not have any settings to connect to my telecom data service, but why is my phone trying to connect to the net when I'm looking at my SMS's? (The SMS's are there and there is no issue with them themselves)

    I don't have a data plan and don't want my bill going up because my phone wants to go off connecting to the net just cause i'm reading SMS's!!

    Am I missing something here? Is there a fix?

    Thanks :)
  2. -aggie- macrumors P6


    Jun 19, 2009
    Where bunnies are welcome.
    You probably need to call your cell provider. It sounds like a problem from their end, unless something else isn't working right. If they can't help you, maybe get a sim replacement or restore in DFU mode.
  3. MWPULSE macrumors 6502a


    Dec 27, 2008
    If your on o2 in the UK http://www.selflearning.co.uk/o2/o2_iphone/ that should help you set up your cellular settings.

    Also regarding your question about SMS data.. if you have the 3G turned on. It by default uses 3G to check SMS's.

    You can turn off 3G in settings>general>network..

    Try that :)

  4. LatterDayAint macrumors newbie

    May 14, 2010
    Reset Settings on your iPhone...

    So, I just started encountering the same phenomenon and when I saw what you guys were suggesting... well, anyway... I just went in under Settings > General > Reset > Reset All Settings. I tried just resetting the Network Settings first, but it did not change things. The unfortunate bit about all this is that you'll have to go and tweak your phone settings to the way you like them again as it will default all your ringtones/sms tones, erase your WiFi passwords, remove any themes you may have running through Winterboard, etc. It's a drastic step, but it worked for me.

Share This Page