What does this message mean?

Discussion in 'OS X El Capitan (10.11)' started by StarShot, Jul 27, 2015.

  1. StarShot macrumors 6502

    StarShot

    Joined:
    Mar 31, 2014
    #1
    The “codesign_allocate” command requires the
    command line developer tools. Would you like to
    install the tools now?


    Choose Install to continue. Choose get Xcode and
    the command line developer tools from the App Store.
    ==================================
    I'm running El Capitan beta 4 and I get the above message quite frequently. So far, I just disregard it, but I'm starting to wonder if it's a scam?
     
  2. mgroot macrumors regular

    mgroot

    Joined:
    Jul 25, 2014
    #2
    I don't know what command you're trying to run but it's highly unlikely that it's a scam
     
  3. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #3
    not a scam; it pops up when i first go to use my (wireless, hp) printer. i click "no", and everything works. been meaning to look into it...
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    I get that also when printing with public beta2 to my HP wireless printer .....

    Screen Shot 2015-07-23 at 11.09.59 AM.png
     
  5. SG- macrumors regular

    SG-

    Joined:
    Jun 8, 2015
  6. MacManiac76 macrumors 65816

    MacManiac76

    Joined:
    Apr 21, 2007
    Location:
    White Mntns, Arizona
    #6
    I got this same message when setting up my Canon wireless printer after reinstalling Yosemite. It is a legit message and simply clicking on Install downloads the tools needed. You do not need to download Xcode to get the message to go away.
     
  7. You are the One macrumors 6502a

    You are the One

    Joined:
    Dec 25, 2014
    Location:
    In the present
    #7
    Got it as well in PB2 when printing. I dismissed it and printing worked fine anyway.
     

Share This Page