What happened to my computer?

Discussion in 'MacBook Pro' started by Zach808, Apr 14, 2010.

  1. Zach808 macrumors newbie

    Mar 21, 2010
    I have to use my Iphone to create this thread, because something is SERIOUSLY wrong with my MacBook pro.

    I was trying to reinstall MacPorts, but the installer was stuck at almost the end, so I had to force quit, and decided to delete the opt folder (where all my macports things are). I deleted that and tried again, but now the installer was stuck "waiting for previous install to finish". I tried deleting opt again, and then remembered the "macports" folder in the applications folder, so I went to my applications folder to delete it.

    When I opened my applications folder, however, every single application above Ical was gone, so I opened up Safari to try recover the files. After looking for about a minute, Safari froze on me, so I opened up my applications folder again, and EVERYTHING except my utilities folder and VMWare Fusion was gone.

    I tried restarting my computer to see if that would fix my problem, but it now won't get past the gray apple. What happened to my computer?

    Please respond ASAP, because if I can't fix the problem, I'm completely screwed.

    I'm running OSX 10.6.3 and Fedora 12 dual boot on my MacBook pro. The rEFIt menu isn't appearing either, so I can't diagnose the probl
  2. Zach808 thread starter macrumors newbie

    Mar 21, 2010
    Sorry, accidentally deselected the text box, and I can't scroll down, so I'll finish the post here.

    The rEFIt menu isn't appearing, so I can't diagnose the problem on my Fedora side.

Share This Page