What HD to buy for the iMac?

iMacBoy

macrumors 6502
Original poster
Dec 24, 2009
363
0
I recently replaced my iMac 21.5" late '09 with a 1TB HD because the original one failed, i bought the 1TB HD from Maplin, and it wasn't anything specific i just went in and bought it, it works on my Mac but the fans max out speed, i have read up about it and people have told me it's because the new temp sensors in macs arnt properly compatible with the HD etc..

Can anyone tell me which HD to buy for my iMac so it will all work normally, and the fans will read the temp correctly and control the fans accordingly, I do not like using the third party software to control my fans, but that's what i am having to do at the moment because the HD fan running at 6000+rpm is mega annoying considering i am only using safari and a few other small apps.

Also what temp should the iMac be at? Because i have noticed even when the fans are maxed out, the back of the iMac is very hot.

Thanks.
 

kpgh554

macrumors regular
Dec 29, 2011
201
1
iver england
I recently replaced my iMac 21.5" late '09 with a 1TB HD because the original one failed, i bought the 1TB HD from Maplin, and it wasn't anything specific i just went in and bought it, it works on my Mac but the fans max out speed, i have read up about it and people have told me it's because the new temp sensors in macs arnt properly compatible with the HD etc..

Can anyone tell me which HD to buy for my iMac so it will all work normally, and the fans will read the temp correctly and control the fans accordingly, I do not like using the third party software to control my fans, but that's what i am having to do at the moment because the HD fan running at 6000+rpm is mega annoying considering i am only using safari and a few other small apps.

Also what temp should the iMac be at? Because i have noticed even when the fans are maxed out, the back of the iMac is very hot.

Thanks.
what make and name was hd took out just replace with same make/name but larger capacity
 

iMacBoy

macrumors 6502
Original poster
Dec 24, 2009
363
0
When i bought the new HD, out of luck (the box the HD was in had no info on it and noone in the shop could tell us what make they were) it was the same make as the original (Toshiba) but still the fans run max. Could it just be that the temp sensor cable is not connected properly?

Thanks.
 

kpgh554

macrumors regular
Dec 29, 2011
201
1
iver england
When i bought the new HD, out of luck (the box the HD was in had no info on it and noone in the shop could tell us what make they were) it was the same make as the original (Toshiba) but still the fans run max. Could it just be that the temp sensor cable is not connected properly?

Thanks.
you could try run hardware test see if that can find prob. if got help in menu bar get info on how. not worry about heat at back mine gets hot too.
 

Similar threads

Replies
0
Views
20
  • r6mile
0
Replies
0
Views
183
  • Fernandez21
0
Replies
0
Views
193
  • Mazz889
1
Replies
1
Views
313
  • dpilat
10
Replies
10
Views
520
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.