What is AppleSpell ??

Discussion in 'macOS' started by CalGrunt, Nov 12, 2005.

  1. CalGrunt macrumors regular

    Oct 21, 2005
    When running the Activity Monitor, one of the process names that comes up quite a bit is AppleSpell. What is that ??
  2. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    It's the service that provides inline spell checking in Cocoa applications such as TextEdit, Mail, Safari, iChat, etc....
  3. tyb macrumors newbie

    Jan 6, 2008
    re AppleSpell

    I would like to disable AppleSpell and would welcome advice as to how to do this in OSX.
  4. abcNoob macrumors newbie

    Sep 13, 2008
    How to get rid of AppleSpell

    Open terminal and type in:

    killall AppleSpell

    It will temporarily stop AppleSpell, but not forever.

    If you want it to stop forever, copy/paste this into a new AppleScript document using Script Editor.

    repeat --repeat will make it go in an infinite loop, until "exit repeat" is called, unless you specify a parameter for "repeat" such as "until expression is true" or "with i from X to X".
    do shell script "killall AppleSpell" --Executes the shell script
    delay 10 --Pauses script execution for 10 seconds
    end repeat

    Save as an Application, then open System Preferences, then click Accounts, then click your account, then click Login Items tab.
    Drag and drop the application into there.
  5. !CodeMonkey macrumors newbie

    Mar 28, 2010
    dead thread?

    There are probably lot's of better articles on the intarwebs that discuss this apple spell thingy that troubles some people. I did however notice the contraindicated suggestion and thought best to donate a few moments of my time.

    Apple spell is a great tool:

    I couldn't possibly imagine why anyone would want to turn it off, unless perhaps you are the greatest speller in the world. If you are concerned about memory usage, consider that apple spell uses approximately the same amount of memory as cron.

    However, if you absolutely needed it gone and gone forever never to return again then locate and delete the file AppleSpell.service (in 10.6 it is locate in /System/Library/Services) This may generate some errors as the launchd attempts to load the service.

    Perhaps the most correct approach would be to use a program like lingon that would allow you to easily edit the .conf files. Though I suppose if you're brave enough you could just find them and edit them yourself. Probably more trouble then it's worth, but if you're gonna do it anyway, ensure you've got a good backup before editing any system files.
  6. jackwindinhair macrumors newbie

    Jul 5, 2012
    I hate AppleSpell

    it rewrites what I'm writing into something completely different, chooses it's erroneous and nonsensical version as I hit the space bar. Is there a simple way to turn it off? Why would Apple embed deep in programming such a ridiculous thing?
  7. mmomega macrumors demi-god


    Dec 30, 2009
    DFW, TX
    So you're talking about autocorrect?

    Open System preferences, Click Language and Text, Select Text tab, uncheck Correct Spelling Automatically.
  8. dyk95112 macrumors newbie

    Oct 18, 2014
    Suspect. Too convenient target for espionage, key capturing, cyberbullying, human predation. All companies complicit. They're just giving themselves away now. 'Come get us' is what I'm getting. Cryptos 2014.
  9. webmaster4o macrumors newbie


    Jul 22, 2015
    New Paltz, NY
    Mine is taking up 3.11 GB of memory right now, and I can't figure out why. Typing is very tedious.[​IMG]
  10. Vala macrumors newbie

    Apr 17, 2016
    --- Post Merged, Apr 17, 2016 ---
    Maybe because it changes my passwords on me while I'm typing them? Changes eMail addresses? Changes my NAME every time I type it?
  11. sandi_t macrumors newbie

    Dec 29, 2016
    Or because 150+ AppleSpell processes were for some unknown reason running, and made typing in any program near impossible, with huge lags in displaying typed text. I killed the AppleSpell processes and turned off spellcheck in preferences, and my system is usable again - I can type in terminal, slack etc.
  12. ChrisChinchilla macrumors newbie


    Nov 7, 2017
    This has been bothering me since High Sierra, and I think I have tracked it down, but I'm not entirely sure, so would appreciate people helping me test what I've found.

    After disabling Address book syncing (I noticed AddressBook in process information for AppleSpell), this seems to have bought the CPU spike down significantly. This isn't an ideal solution, but as I said, before going any further I'd like to know if this helps others.
  13. iSerghei macrumors newbie


    Mar 27, 2018

    Well it is mine

    Screen Shot 2018-03-27 at 9.22.37 PM.png
  14. CescoAiel macrumors newbie

    Oct 6, 2014
    I just killed AppleSpell on mine, because it was slow and the fans were on max continuously... It was 29.5GB in size!!!

Share This Page