what is iChatAgent and why is it "Not Responding"?

wkw

macrumors 6502
Original poster
Mar 23, 2004
287
7
Eugene, OR
Why am I seeing this in my Activity Monitor? Is anyone else having this issue? This happens whenever I run iChat. Also, whenever I send pictures or files via iChat I get error messages when I try to continue chatting. I have to quit iChat and restart it in order to get chatting again.

any suggestions?

thanks

bill
 

Attachments


eva01

macrumors 601
Feb 22, 2005
4,714
0
Gah! Plymouth
I have it all the time, but it doesn't crash my chatting

oh btw it is what keeps track of your contacts, try quitting it in activity monitor and watch your accounts go offline ;)
 

mkrishnan

Moderator emeritus
Jan 9, 2004
29,641
12
Grand Rapids, MI, USA
Sounds like you need to go on a bug hunt.... :( For a corrupted plist file, that is.

Try these (where . is the library in your user folder -- find | grep results, natch ;) ):

./Preferences/com.apple.iChat.AIM.plist
./Preferences/com.apple.iChat.Jabber.plist
./Preferences/com.apple.iChat.plist
./Preferences/com.apple.iChat.SubNet.plist
./Preferences/com.apple.iChatAgent.plist

In particular -- try killing the iChatAgent, quitting iChat, and then moving the iChatAgent.plist file out of there and restarting. If nothing bad happens, or something good happens, delete the file you moved out of there.

Also try deleting the contents of the caches/ichat/ folder in your library.
 

munkle

macrumors 68030
Aug 7, 2004
2,580
0
On a jet plane
mkrishnan said:
Sounds like you need to go on a bug hunt.... :( For a corrupted plist file, that is.
I tried most of the above but it still comes back stalled everytime you restart iChat. A tad annoying but as far as I am aware it doesn't affect anything, so I've just chosen to ignore it.

These things seem to happen every now and then. Like that constant item that came up when repairing permissions under Panther, and the Library/Widget that needs repairing under Tiger.


Edit: A useful tool in hunting down corrupt .plist files is Preferential Treatment, which will do the terminal grunt work for you.