What is the issue with permissions in Mac OSX?

Discussion in 'Mac Basics and Help' started by Matt-Man-Plus, Feb 16, 2010.

  1. Matt-Man-Plus macrumors regular

    Joined:
    Mar 20, 2008
    #1
    Why can't they figure this thing out, seriously? Or is it just me? I switched to a Mac a little over a year ago. I have a Time Capsule that I use for TM backups. Plugged into the TC via USB is an external HD where I keep my iPhoto library. The library used to be in the shared folder on our MB so me and my wife could access it from either of our user accounts. Every once and a while, one of us would open iPhoto but we couldn't enlarge or edit any of the pics. You could see the thumbnails no problem, just couldn't do anything with them. Permissions problem apparently

    After contacting Apple support, they said we would be better off putting the library on an external HD. Make a disk image and set it to "ignore ownership".
    I beleive this is the document for it. http://support.apple.com/kb/HT1198

    I followed that document to the letter. It worked for a little while and then the all of the sudden the disk image would mount on my or my wife's desktop with the little red line through it, indicating we don't have suffeicient permissions...WTF?

    Now I don't know why, but the "ignore ownwership" had to continually be re-checked. How did it get un-checked is something i'd like to find out. Now I'm having problems even finding that option at all.

    I've done a "repair permissions" already in disk utility. Just seems like the whole permissions thing isn't quite there yet in terms of reliability. Anyone having similar issues? Anyone have a solution? Thank you in advance.
     
  2. CylonGlitch macrumors 68030

    CylonGlitch

    Joined:
    Jul 7, 2009
    Location:
    SoCal
    #2
    I don't have a solution for you, but I have no problems like this at all. I know that you can apply permissions, just make sure that once you set the permissions that you apply it to all the folders below it. This is an extra step of going to the little gear icon and selecting "Apply to Enclosed Items". If you want everyone to have access to it, and it being on an external drive, it sounds like you do, try getting info on the top folder (cmd-I with the folder selected) then, if locked, unlock it with the admin name and password. From there check to see if "everyone" is listed under the Sharing & Permissions -> Name field. If it is, make sure that under Privilege it says "Read & Write" not just "Read Only". Then click the gear icon (next to the +/-) and select "Apply to Enclosed Items". This will make sure everything in that folder and the subfolders will have the same permissions.

    Now you should have no problem reading and writing it. Permissions are inherited from the person copying / moving the files around. Thus sometimes they aren't the way you want them to be, but this is how it should be. It is basically the way Unix does it.
     
  3. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #3
    OSx permissions are basically *NIX. It can be quite confusing for a novice to understand this. One thing you have to be careful of is to NOT go in and start changing permissions if you don't know what you are doing - this easily leads to an unbootable system.

    Repair permissions doesn't solve problems with the user's own files; it's basically for system files so that the system will run properly. You can set files in your own folders to all kinds of weird permissions and repair permissions is likely to ignore it.
     
  4. carlgo macrumors 68000

    Joined:
    Dec 29, 2006
    #4
    I guess I am lucky. I haven't ever had to ask for permission or whatever that stupid thing is. Never a dialogue or a setting or anything. Good. The very word is revolting.

    Knock, knock on wood...
     
  5. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #5
    The very word is at the core of what makes Mac OS X so secure. It's not designed to restrict you, it's designed to keep malware, would-be hackers, and unauthorized (non-admin) users out of where they shouldn't be.
     
  6. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #6
    Never had an issue on OSx either; I don't fool around with permissions.

    On Unix, however, when I was working I used to have days when I had to sweat blood to straighten out screwed up permissions.
     
  7. maxrobertson macrumors 6502a

    Joined:
    Jun 15, 2006
    Location:
    Jakarta
    #7
    I've never had any experiences with permissions acting up in such a way, no.
     
  8. Matt-Man-Plus thread starter macrumors regular

    Joined:
    Mar 20, 2008
    #8
    It's been a real point of frustration. Just now I had to (again) check off "ignore ownership of this volume". I'd just like to know how it mysteriously gets unchecked. I'm actually considering re-installing Snow Leapord as a clean install and staring fresh. It would really suck setting everything back up again but I'm afraid I've tried everything else.
     

Share This Page