What on earth has happened to "sleep" function on 10.9.2?!

Discussion in 'OS X Mavericks (10.9)' started by rafithegreat, Mar 16, 2014.

  1. rafithegreat macrumors newbie

    Joined:
    Jul 27, 2013
    #1
    So, ever since I've upgraded to the newest version on Mavericks, I'm having an enormous paining the arse with my attempts at getting my MBA 2013 13'' 256 8 to go to sleep..!

    It started with the hot corner that made the display turn off, not triggering the sleep functions, which I thought "well, OK, maybe they meant to have it so I can listen to music with the display off".
    Since then, I've been "degraded" to having to press the power button for a couple seconds, then select the "sleep" option (closing the lid itself also did not put it to sleep).

    This morning, after having pressed the "sleep" option in the popup box, I wake up to a 0% battery.. Wonderful.

    Can anyone explain what's going on? I saw some thread in the Apple communities mentioning sleeping issues, but not quite since 10.9.2. Moreover, I have changed none of the settings I had on 10.9.1 (meaning, power-nap is only enabled on charge, hard disks are put to sleep when possible etc).


    So - any thoughts?

    Thanks!
     
  2. bbfc macrumors 68030

    bbfc

    Joined:
    Oct 22, 2011
    Location:
    Newcastle, England.
    #2
    Closing the lid should put the machine to sleep. Holding the power button down for a few seconds will bring up the menu and choose sleep.
     
  3. Gjwilly macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #3
    Since 10.9.2 tapping the sleep button does nothing, holding the sleep button triggers sleep, and holding it even longer brings up the menu.
    If you keep getting the menu then you're holding it too long.
    You just need to practice your timing.
     
  4. rafithegreat thread starter macrumors newbie

    Joined:
    Jul 27, 2013
    #4
    So simply using the hot corner to switch off the display won't trigger the sleep mode any longer? That's a bit of a shame.. =\

    Oh well, thanks for the heads up! :)
     
  5. AllergyDoc macrumors 65816

    AllergyDoc

    Joined:
    Mar 17, 2013
    Location:
    Utah, USA
    #5
    The sleep button now takes 2-4 presses before my 2012 27" iMac goes to sleep. Sleep is easily activated by the menu commands, though. It's slightly annoying.
     
  6. ds705 macrumors member

    Joined:
    Apr 7, 2013
    #6
    Weird, it works normally on my MBP 2012
     
  7. rafithegreat thread starter macrumors newbie

    Joined:
    Jul 27, 2013
    #7
    OK, so 1 week later, and still absolutely rubbish.
    Can't make my Mac go to sleep - there is no way of getting it to work. I've used the power button, selected the sleep option, yet the battery drain is horrible - I leave the Mac at over 90% before I go to bed, and in the morning it's at 10%, or even plain dead.

    What the hell is wrong with Mavericks 10.9.2? Why have they made it impossible to sleep the machine? I've tried resetting the SMC, tried changing all possible energy saver options, all sorts of command line prompts - still, nothing new.

    Is there any other option apart from literally shutting down the machine every time I'm done using the machine?
     
  8. HomerThompson macrumors newbie

    Joined:
    Nov 26, 2013
    #8
    Is it a laptop right? Why don't you close the lid?
     
  9. rafithegreat thread starter macrumors newbie

    Joined:
    Jul 27, 2013
    #9
    Because closing the lid also does not make it go to sleep?
    I did in fact try that one more time last night and woke up to a dead laptop.. bliss. really getting on my nerves now as i don't really want to shut down the mac whenever i'm not using it - real pain in the arse.
     
  10. oneMadRssn macrumors 68040

    oneMadRssn

    Joined:
    Sep 8, 2011
    Location:
    Boston, MA
    #10
    Try deleting /Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist

    Then rebooting.

    That should completely reset all your power settings. See here for more info http://forums.macrumors.com/showthread.php?t=1391320

    That might help, if your pmset settings got all messed up.
     

Share This Page