What Snow Leopard files are for Mini Displayport audio in?

Discussion in 'iMac' started by WilliamG, Nov 11, 2010.

  1. WilliamG macrumors 604

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #1
    For some reason on my i7 iMac I've lost the ability to play audio from Mini Displayport devices like my MacBook Pro/PS3/360 etc when they're connected. It was working up till a few days ago. Regular sound from the iMac works great.

    I did a fresh install on an external drive of SL 10.6.2, and audio then works fine over Displayport IN. So, clearly some files changed on 10.6.4/10.6.5, and I'm trying to find out what those files are.

    Anyone able to help?

    All help appreciated! I'd rather not have to reinstall my OS for this seemingly minor issue...!
     
  2. WilliamG, Nov 11, 2010
    Last edited: Nov 12, 2010

    WilliamG thread starter macrumors 604

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #2
    Figured it out!

    Go to your HD: Then Library/Preferences/Audio, and delete the .plist file in there. Reboot, and then your audio will work again, so for anyone else with this issue, that's how you fix it. :) The OS recreates that file when you reboot. I had two .plist files in there, and deleted both. One came back on reboot, and the other at some point while I was using audio. Not sure why the audio issue happens, but at least we can fix it!
     
  3. Jarland macrumors regular

    Joined:
    Oct 10, 2006
    #3
    You just saved my iMac from being thrown out the window. Thank you sir!
     
  4. WilliamG thread starter macrumors 604

    Joined:
    Mar 29, 2008
    Location:
    Seattle

Share This Page