What the What? Stuck on Blue Screen during startup.

Discussion in 'macOS' started by thestaton, Nov 9, 2009.

  1. thestaton macrumors 6502

    Joined:
    Jan 19, 2006
    #1
    Culprit: iMac 20" Early 2006. Apple Care expired this year :(

    OS: Snow Leopard Bootcamp Win 7, Ubuntu 9.10.

    Problem: I felt I would be nice to the iMac and shut it down after a hard days work. I woke up the next morning, turned it on, and it loads up past the gray screen, then goes to the dark blue snow leopard screen. From there I DO NOT get a mouse pointer. I get zip, zilch, nothing.

    I have let it sit over night just to make sure it wouldn't surprise me.

    Remedies tried:

    Booting to safe mode. Boots fine but when it gets to the blue screen it doesn't do anything else.

    Booting to single user mode. From there I renamed the com.apple.loginwindow and the com.apple.startup file. Didn't do anything.

    Resetting PRAM, VRAM, ram, jingle bell, any key, * key, I've tried resetting everything possible and not possible. WHY computer gods? WHY?

    Tried to boot the hardware test (D) but it never did anything.

    Boot via verbose and it boots just fine, and doesn't throw any errors before going to said blue screen.

    Tried booting from snow leopard disk, loads fine. When it gets to blue screen it doesn't go any farther.

    I hooked it up via target disk mode to my macbook pro and copied all the files off the drive that I might need. I then put the snow leopard disk in the mbp and installed snow leopard back to the drive. Rebooted. Same problem.

    Do you need to format the drive w/ disk utility before re-installing osx? If so I'm going to lose the bootcamp partition and could inevitably end up with nothing working.

    Here's what I learned from google:

    It's probably a bad hard drive - yeahhhh. I get to spend 6 hours taking this damn thing apart.

    It could be the hard drive fan has died thus over heating it.

    If you have an older iMac and one of those new silver shiny keyboards. It doesn't do **** at start up, so you could waste an hour of your day envisioning the death of said silver keyboard. Only to find out you have to use the original. Really Apple? Really?

    Thanks for the help macrumors.

    Any gurus out have any other ideas I could try?
     
  2. thestaton thread starter macrumors 6502

    Joined:
    Jan 19, 2006
  3. webgoat macrumors 6502a

    webgoat

    Joined:
    Sep 20, 2007
    Location:
    Austin, TX
    #3
    if a standard reinstall of snow leopard failed to get you going and you have all your files backed up then erase and 0 your drive to a single partition mac os x extended journaled guid partition table and install snow leopard again. any mishaps along the way and you know you've got a hardware issue
     
  4. thestaton thread starter macrumors 6502

    Joined:
    Jan 19, 2006
    #4
    Thanks for the tip. I tried this and the install went great, but still blue screen on the iMac. I put the iMac in target disk mode and booted the hard drive on my mbp with no problems.

    So I'm going to tear apart the iMac today.

    Any other tips / tricks to try?
     
  5. thestaton thread starter macrumors 6502

    Joined:
    Jan 19, 2006
    #5
    Spent all day trouble shooting and now I have a system that dual boots win 7 & Ubuntu 9.10

    So long OSX.
     
  6. Zyniker macrumors 6502

    Joined:
    Feb 14, 2008
    #6
    And what precisely was wrong?

    We'll just ignore the snarky comment concerning OS X.
     
  7. thestaton thread starter macrumors 6502

    Joined:
    Jan 19, 2006
    #7
    I was unable to determine any reason for OSX not to work. I performed the AHT off the dvd that came with my system and it reported the hardware was fine.

    I then loaded disk utility and cleared off all the partitions, and re-installed Snow Leopard via target disk mode off my mbp. Same problem blue screen on startup.

    So I said screw it, and dual installed win 7 & Ubuntu 9.10 They are both working great, and the iMac is back to work just without OSX. If this goes well I plan on converting the MBP over in a few weeks.

    This will also be the last apple systems I own, just to much difficulty when it comes to trouble shooting hardware or software issues. And it didn't help matters that this happened 6 months after the warranty expired.
     

Share This Page