What to do when random apps crash at launch?

Discussion in 'iPad' started by LincolnsiPod, Sep 17, 2012.

  1. LincolnsiPod macrumors 6502

    Joined:
    Nov 20, 2009
    #1
    My iPad 2 seems to be experiencing an issue where an app crashes at launch. You tap the app to start, there's a brief flicker or flash for a second and then you're returned back to the home screen. Even force quitting it doesn't work, I wind up having to delete the app from the iPad, and re-install it, only to see it happening all over again.

    So far it's happened with Y! Messenger and EyeTV, though it recently happened with Intellicast as well, an app I always found to be pretty stable. It's like the apps are getting infected here, lol. I find it odd that they would all exhibit the same behavior in that you can't even start the app, and force quitting also doesn't help. I'm wondering if one of these apps is somehow causing problems for all the others?

    Has anyone experienced this before? Was it a matter of just getting rid of the problematic apps or is there a trick I can try that could help stop these crashes? is it possible something in the iOS might have gotten corrupted too?

    I read downloading offending apps via iTunes instead of directly to the iPad can help as well, something I may try this week. In the meantime I have Y Messenger deleted for now, as that has gotten the worst reviews.

    Any insight/advice appreciated.
     
  2. HarryLarry macrumors newbie

    Joined:
    Sep 17, 2012
    #2
    You might want to try rebooting your iPad. If that doesn't fix the problem, backup to iTunes and then do a restore. If it sill doesn't work, write an app review describing the problem. Developers do listen!
     
  3. LincolnsiPod thread starter macrumors 6502

    Joined:
    Nov 20, 2009
    #3
    Curious, how would a restore fix anything if I'm simply restoring the same content I had before, including the apps that crash? Might try that later this week though.
     
  4. donnaw macrumors 65816

    Joined:
    Apr 19, 2011
    Location:
    Austin TX
    #4
    First go to Settings> General>About>Diagnostic and Usage> Diagnostic and Usage Data and see if you see a bunch of low memory issues.

    If you do then go to the MultiTask tray and close all the apps (touch one and hold it until they all wiggle then touch the little 'x' on each one.

    I know IOS is supposed to handle the memory allocation but I've had the same issue on my IPad 2 and something doesn't seem to release memory correctly. I usually run into it with Safari but some other apps will cause a crash too.
     
  5. Agent-P macrumors 68030

    Agent-P

    Joined:
    Dec 5, 2009
    Location:
    The Tri-State Area
    #5
    That was my thought about that process too. However I have had that fix random problems in the past, so it's worth a try. You have nothing to lose. Worst case scenario is to restore and set up as new.
     
  6. LincolnsiPod thread starter macrumors 6502

    Joined:
    Nov 20, 2009
    #6
    Sounds good, if it starts crashing again I'll check the memory usage and see if that's been an issue, then try a restore.
     
  7. nixiemaiden macrumors 6502a

    Joined:
    Jun 21, 2010
    #7
    I run into the same issue a lot in Safari and find that rebooting seems to fix it for a few days.

    I usually don't ever close my apps and they just go into the tray at the bottom and rebooting clears those all out.
     
  8. LincolnsiPod thread starter macrumors 6502

    Joined:
    Nov 20, 2009
    #8
    BTW, is this an iCloud backup or a backup via iTunes?
     
  9. Agent-P macrumors 68030

    Agent-P

    Joined:
    Dec 5, 2009
    Location:
    The Tri-State Area
    #9
    I think when I did it, I restored from an iTunes backup because it's quicker to restore than an iCloud backup. But it shouldn't matter since they back up the same info.
     
  10. kaniSS macrumors newbie

    kaniSS

    Joined:
    Sep 9, 2012
    Location:
    Sydney Australia
    #10
    I had the same problem and what I did was plug it into itunes and go to Authorise this computer, then synced the apps and it worked.
     
  11. LincolnsiPod thread starter macrumors 6502

    Joined:
    Nov 20, 2009
    #11
    I just did that today. Also installed iOS 6 as well on top of that too. O_O

    Basically I followed everyone's advice, backed up, rebooted, reset the iPad, restored it, synced via iTunes and finally added authorization. I hope that clears it all up. I checked diagnostics but there seems to be no memory usage problems, so I have that going for me. Hopefully iOS 6 will improve stability too.
     

Share This Page