Whatever happened to Airport Disk(s) in Leopard?

Discussion in 'macOS' started by instantations, Oct 27, 2007.

  1. instantations macrumors newbie

    Joined:
    Oct 27, 2007
    Location:
    Lyon, France
    #1
    I've already posted this on the Apple.com board but I'll duplicate it here :)

    I've upgraded to Leopard and I can't seem to understand what happened to Airport Disk.

    No more Airport Disk Utility... no more auto-mounting at start-up... :eek:

    I've got 2 USB drives hooked to my Airport Extreme Base Station and whenever I mount one from the new Finder, I can't mount the other. :confused:

    Anyone with better luck?

    (On the other hand, without really trying, Time Machine is now backing-up to one of my Airport Disk... All I did was set up Time Machine to use the drive when it was wired... and that is cool)
     
  2. 98Sierra macrumors newbie

    Joined:
    Oct 27, 2007
    #2
    Not really..

    I have spent the last five hours on the internet trying to find an answer.:confused:

    After finding that my AirPort Disks did not auto mount and that the utility disappeared I tried reinstalling it from the original APBS disk... didn't work. The only way I have found so far is to go into the finder window and select my APBS as a server and then select the drive. At least I got my iTunes and Podcasts back.

    But I have not found a way to get the server to mount on startup.
     
  3. wackymacky macrumors 68000

    wackymacky

    Joined:
    Sep 20, 2007
    Location:
    38°39′20″N 27°13′10″W
    #3
    Airport not supported by TM


    You're able to use time machine on a Airport disk?

    I don't seem to be able to get it to work. It is really the only way I want to set up TM.

    A couple of months on the TM page info it stated it would support Airport, then that reference disappeared two weeks ago before the launch, and now Apple officially state it isn't supported, with this appearing on the Apple site the day of Leopard release:

    http://docs.info.apple.com/article.html?artnum=306833

    I’ll have to keep trying to get it to work.

    I assume they will sort it out in an update soon I hope.
     
  4. notsofatjames macrumors 6502a

    notsofatjames

    Joined:
    Jan 11, 2007
    Location:
    Wales, UK
    #4
    there was a post showing a work around on this not so long ago. I'll sure I can find it!
     
  5. notsofatjames macrumors 6502a

    notsofatjames

    Joined:
    Jan 11, 2007
    Location:
    Wales, UK
    #5
    1) disconnect airport disk and plug into computer as a USB drive directly.
    2) Set up time machine to use this volume.
    3) In terminal cd to volume "cd /Volume/HDD"
    4) In terminal "touch .com.apple.timemachine.supported" this will create an invisible file.
    5) In terminal "sudo chown root:admin .com.apple.timemachine.supported"
    6) In terminal "sudo chmod 1775 .com.apple.timemachine.supported"
    7) In terminal "ls -l -a" the .com.apple.timemachine.supported file should be -rwxrwxr-t
    8) eject disk, unplug from mac, plug into Airport.
    9) mount at mac using connect to server in finder (command k) and afp://airportname.local./HDname
    10) see if time machine now sees the drive and tries to use it.
     
  6. drlunanerd macrumors 65816

    drlunanerd

    Joined:
    Feb 14, 2004
    Location:
    UK
    #6
    11) Skip steps 3 to 7 ;)
     
  7. notsofatjames macrumors 6502a

    notsofatjames

    Joined:
    Jan 11, 2007
    Location:
    Wales, UK
    #7
    lol, i hadn't tried it or anything, just copy and paste. If its easy enough for people to do this for an airport disk, it shouldn't be too difficult for apple to implement it in the time-machine app.
     
  8. drlunanerd macrumors 65816

    drlunanerd

    Joined:
    Feb 14, 2004
    Location:
    UK
    #8
    What worries me is if it's so easy why did Apple drop support for it? Data corruption issues? Access Control List issues? I would advise not to rely on this as your main backup mechanism for now. A very cool feature, yes, but the risk-benefit is looking shaky at the moment.
     
  9. notsofatjames macrumors 6502a

    notsofatjames

    Joined:
    Jan 11, 2007
    Location:
    Wales, UK
    #9
    reliability is probably apples main concern. If it doenst work, apple doesnt ship it (certain exceptions). Back-up solutions need to be reliable also, so apple would have had a lot of bad press for an unreliable system.
     
  10. tony710 macrumors member

    Joined:
    Jul 4, 2007
    Location:
    Columbus, OH
    #10
    I just installed the AirPort Disk Utility from the original disk.

    Install and everything went fine and works like it did in Tiger for me.
     
  11. tcfenstermaker macrumors newbie

    Joined:
    Oct 27, 2007
    #11
    AirPort Shared Disk Appears Completely Broken in Leopard.

    Then you've gotten further than me. My APBS shows up in the Finder's "Shared" list, and sometimes clicking on it will show me the shared drive. But clicking on the drive just spins the indicator in the lower right. Occasionally it won't even let me get that far, saying the "connection failed." Clicking on "Connect as" gets me nowhere.

    The airport disk utility has disappeared from the status bar, as has been noted, and the finder can't cope at all, at least for me.

    I've found that sharing the disk over the AirPort has been very unreliable even under Panther (the disk frequently disappearing or hanging while I browsed, requiring a reconnect); now it appears to be completely broken under Leopard, at least for me.
     
  12. gdiogenes macrumors newbie

    Joined:
    Oct 28, 2007
    #12
    Workaround for Airport Disk in Leopard

    One option is to open Account Preferences/Login Items and then go in Finder/Shared and drag the volumes you want from Airport Extreme's subtree to the Login Items.

    Now every time you log in Leopard will try to mount that share.

    The bad thing is that it will try to mount it even if you're not connected to your Airport Extreme network.

    I guess Apple should fix this sometime soon.
     
  13. SafariX macrumors member

    Joined:
    Jan 29, 2004
    #13
    I have had the same problems with my two Western Digital MyBook 500GB external USB2 drives (2 of them hooked into a USB hub into my AEBS).

    My major concern, is that my iTunes media is stored on one of them, and performance/throughput JUST through iTunes has been abysmal. Video stutters, pauses, freezes, because the data throughput cant feed the file to my MBP fast enough. No settings have changed since my upgrade to Tiger. Interestingly, I can copy files to both drives at 4.0MB per second - but they cant serve files that stream at 150k/sec through iTunes!

    I have tried disabling WPA, adjusting channels, multicast rates, etc to no avail.

    Anyone have similar symptoms or a solution (in addition to the Airport Disks not automounting)?
     
  14. /dev/toaster macrumors 68020

    /dev/toaster

    Joined:
    Feb 23, 2006
    Location:
    San Francisco, CA
    #14
    I was trying it on the last seed, it worked but it was rather unstable. There would be days I would wake up, look at my machine and realize it didn't backup for the past 12 hours.

    I am guessing that is why they removed it, because they couldn't fix it in time. I bet in the first 2 updates they will fix it.
     
  15. SafariX macrumors member

    Joined:
    Jan 29, 2004
    #15
    This solved the issues I was having (stated above), and should help everyone having AirDisk issues (performance / iTunes etc). I got this post from the Apple Support forums.

    "Okay well I fixed mine. After searching since Fri for a solution I finally found the issue. Before I proceed, let me first say that you shouldn't attempt this fix unless you know what you are doing. I'm not an Apple Engineer and don't know how this will effect your computer. I did it to mine and it worked... That said...

    From what I can tell the Airport Base Station Agent (that lives in Core Services) that ships with Leopard appears to be broken. (At least I think it shipped with Leopard or maybe it was on the AEBS install disk 2.0, I'm not sure anymore... My mind is kinda mush now...) But at any rate I figured out that the version of the Airport Disk Utility that I had regardless of where it came from was not the newest version. I had 1.2 and the newest was 1.2.1. I downloaded the Airport 2007-002 update (AirPortUtility521.dmg) from Apple Support and tried to install it. It failed because it said I already had the latest software. I assume this is because Leopard shipped with Airport Utility 5.2.2 and that update had 5.2.1. So I got creative and did a show contents on the package and extracted the archive that was in there. I found there were 4 files in there.

    Applications/Utilities/AirPort Disk Utility (Ver 1.2.1)
    Applications/Utilities/Airport Utility (Ver 5.2.1)
    System/Library/Contextual Menu Items/AirPort Disk Menu.plugin (Ver 1.2.1)
    System/Library/CoreServices/AirPort Base Station Agent (Ver 1.2.1)

    So basically I removed the AirPort Base Station Agent from my login items, restarted, and then copied all these files (Except for the Airport Utility, I kept the 5.2.2 that shipped with Leopard) into their respective directories (Which is basically the same as the folder paths in the archive.), added AirPort Base Station Agent back to my startup items, and then did one more restart. Upon login life was good and now AirPort Disk Utility properly launches, puts the icon on the menu bar next to the time and maps my shared and private drive. The reason you have to remove the Agent and restart is because you can't copy over the file if its open. You will need to play with the permissions on the other files to get them to copy. Hopefully one of the Apple Engineers will read this and figure out exactly what is missing. (Note the Agent 1.2.1 is about 800k where 1.2.2 was about 300k... seems like something is missing...)

    On another note (as long as the Apple Engineers are reading..) in Leopard when you click on "Shared" in the sidebar from Finder, it lists the AEBS. When you click it, it only shows the "Shared" volume from the attached drive and not the private drive for the logged in user. Those who are used to using the account mode will find this very annoying and should be fixed. "
     
  16. thehitman123 macrumors newbie

    Joined:
    Oct 30, 2007
    #16
    I've just had the most amazing thing happen.

    Well, let me start from the beginning.

    I bought Leopard on the weekend. Nearly everything worked quite well. Well, except for logging onto Airport Disk via Airport Extreme.

    I had bought Airport Extreme in anticipation of using Time Machine. However, I initially had trouble setting the whole thing up. Eventually, the only way I could get Airport Disk working was setting up an account, transferring files into my account and connecting through the network shares.

    Anyway, back to the story. After installing Leopard, I was pulling my hair out trying to connect Airport Disk. Airport Extreme and the USB Hard Drive were visible in my shared folders but I could not see my files on the hard drive. This drove me nuts for about 3 days.

    I decided to set up a trial .mac account so that I could test out Back to My Mac to connect up my I-Mac at work with my Macbook at home. As part of doing this, I switched on the sharing features in System Preferences on both computers.

    Imagine my surprise that my shared folder came up with a new folder called Airport which contained the contents of my hard drive. And even more surprisingly - Time Machine starting working! Over Airport Disk, no less.

    I have no bloody idea why is this case but everything is going swimmingly after days of anxiety and frustration. Ironically, Back to My Mac hasn't worked yet even though this was my original objective.
     
  17. beheriter macrumors newbie

    Joined:
    Mar 1, 2011
    #17

    Actually its better if you just connect the disk direcly to your computer and change the permissions directly
     
  18. njaremka macrumors 6502

    Joined:
    May 11, 2010
    #18
    not to mention going back in time 3 years to bump a thread :eek:
     

Share This Page