What's going on?

Discussion in 'iPhone' started by BKIDD24, Aug 4, 2012.

  1. BKIDD24 macrumors newbie

    Joined:
    Aug 4, 2012
    #1
    I Just got my phone back from getting its screen repaired and I restarted it a couple of tines to see if I could get the sound to work and now my apps are showing up as blank white icons. My phone isn't jail broken or anything. Btw it's an iPhone4.

    Please help?
     
  2. cyks macrumors 68020

    cyks

    Joined:
    Jul 24, 2002
    Location:
    Westchester County, NY
    #2
    This is why I only trust Apple to do any repair work.

    Since you just got it back, my guess would be that the 'repair' shop did something wrong. Bring it back to them and (if you're lucky) they might fix the problems they caused.

    Good luck.
     
  3. BKIDD24 thread starter macrumors newbie

    Joined:
    Aug 4, 2012
    #3
    The place I had my phone sent from was terrible. I got my phone back with no sim card, no sound and no vibrate. The store then tried to tell me that I couldn't prove they broke they sound and they gave me a sim card and said we had to cut it to make it fit. It was the wrong size sim card and she was using a thick metal thing to open the sim card spot and scratched the opening and said it was normal.

    And thanks
     
  4. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #4
    Question for anyone: If they took his SIM do they need to be concerned with their account or unauthorized usage?
     
  5. irDigital0l Guest

    Joined:
    Dec 7, 2010
    #5
    Yea, this isn't good at all.
     
  6. subrar08 macrumors newbie

    Joined:
    Jul 7, 2012
    #6
    that's right, these issues are often heard, my friend too has to encounter such type of issue.
     

Share This Page