What's preventing sleep?

Discussion in 'Mac Help/Tips' started by withnail, May 29, 2003.

  1. withnail macrumors regular

    Feb 8, 2003
    A while back, I posted a thread about my Ti Powerbook 1GHz not going into sleep mode after the specified time in Energy Saver preferences. I am still seeing this behavior and was wondering if there is there any tool or method to diagnose what process(es) is/are keeping the computer from going to sleep?

    I have (I assure you) checked to make sure there are no external devices attached to it, and that there are no open applications. I looked at the process table from Terminal, and I can't see any suspect processes that should be keeping it awake. The only time it will enter sleep mode is when it's running on battery and the charge is almost gone. The rest of the time the display will dim in half the time specified in "Put the computer to sleep after it is inactive for" setting, and then it will turn totally off after the rest of the time has elapsed, but it fails to go completely into sleep mode - any movement on the touchpad will cause the display to come back on, not just a button press). I can manually force it to sleep through the Apple menu, so it's not as if the hardware part of it is failing. Oh, and I tried resetting the PMU, to no avail...

    Any advice is appreciated!
  2. Hockey Nut macrumors member

    Feb 15, 2003
    Battle Creek
    My PM does this on occasion. Go to disk utilities and repair your disk permissions. It works for me.
  3. withnail thread starter macrumors regular

    Feb 8, 2003
    ...already tried that. I'm at 10.2.5 - maybe up'ing to 10.2.6 will help, although I read the release notes and it doesn't look like anything resembling this was addressed.

Share This Page