What's the latest firmware to unlock?

Discussion in 'Jailbreaks and iOS Hacks' started by Frenchiex, Oct 12, 2010.

  1. Frenchiex macrumors member

    Joined:
    Oct 12, 2010
    #1
    I have a 3g iphone with firmware 2.2 that's already jailbroken/unlocked but i haven't used it in a year so i don't know how to go about updating my iphone to 4.1 and rejailbreaking/unlocking.

    Which program should i download and how do i go about updating my iphone to 4.1 without changing that baseband. Do i update my iphone through the jailbreak program and do i need to update to any previous version before 4.1?
     
  2. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #2
    Ultrasnow only unlocks baseband 5.13 (4.0.2 firmware) or below. Thus, if you need the unlock, do not use any JB method that requires you to update your phone to official 4.1. Wait for new version of pwnagetool.

    With the first few release 3G phones, there's a small chance that you might have the 5.08 bootlooder which allows you to downgrade the baseband using Fuzzyband. If you have this, you can update to 4.1 and downgrade baseband = unlock.
     
  3. Frenchiex thread starter macrumors member

    Joined:
    Oct 12, 2010
    #3
    ok so can i just use redsnow to update and jailbreak my iphone to 4.0.2 firmware and after that use ultrasnow? The problem is i don't know how to update to 4.0.2. Do i do that through redsnow? will redsnow even let me update from such an older version or what =/

    Also i use windows so i cant use pwnagetool.

    edit: do i have to use tinyumbrella to update my iphone to 4.0.2?
     
  4. Frenchiex thread starter macrumors member

    Joined:
    Oct 12, 2010
    #4
    so really i just need help on the last part of my question. Do i need to use tinyumbrella to go from 2.2 to 4.0.2? go through the process, it fails baseband, and restore it through itunes as 4.0.2?
     
  5. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #5
    Tinyumbrella only saves the baseband on IP4. Google for instructions on how to update to 4.0.2, and then, JB with Redsnow.
     
  6. Frenchiex thread starter macrumors member

    Joined:
    Oct 12, 2010
    #6
    i did which all relate to iphone 4, arrr why is it so hard to do this. Does baseband still matter? cant i just update or will that block me from unlocking with ultrasnow..
     
  7. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #7
    Ultrasnow can only unlock certain baseband. Thus, YES, it makes a huge difference. For the final time, if you update to 4.1, the baseband will also be updated to 5.14 which is currently can't be unlock.
     
  8. Frenchiex thread starter macrumors member

    Joined:
    Oct 12, 2010
    #8
    okay so how do i go about updating my iphone 3G to 4.0.2 or even 4.0 without changing it's current baseband? I googled like you said going through the first 4 pages and changing the search but it's all related to iphone 4 or using tinyumbrella + itunes which i can't use like you said. I'm pretty sure i have the original baseband, it never changed to begin with.

    by "With the first few release 3G phones, there's a small chance that you might have the 5.08 bootlooder which allows you to downgrade the baseband using Fuzzyband. If you have this, you can update to 4.1 and downgrade baseband = unlock."
    your saying i should update to 4.1 through itunes and use fuzzyband to downgrade it back to what the baseband was before the update? i thought you couldn't change baseband to it's original.
     
  9. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #9
    You are searching wrong. With 3G, the baseband will always change after updating. The IP4 is only device you can use TU to keep currently baseband. Thus, you need to update to firmware which still can be unlock with Ultrasnow. Ultrasnow supports up to the 5.13 Basband = 4.0.2 firmware. So, you can update to 4.0, 4.0.1 and 4.0.2, but not 4.1.

    Question would be if you have 5.08 bootloader. If NO, you can't update to 4.1. If YES, you can update to 4.1 and downgrade baseband with Fuzzyband.
     
  10. Frenchiex thread starter macrumors member

    Joined:
    Oct 12, 2010
    #10
    okay so i can just update from 2.2 to 4.0.2 regularly and after it's updated to 4.0.2 use redsnow to jailbreak and use ultrasnow to unlock my phone. correct?
     
  11. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #11
    YES.
     
  12. Frenchiex thread starter macrumors member

    Joined:
    Oct 12, 2010
    #12
    lol why couldn't you just said that to begin with that's all i wanted to know. ty
     

Share This Page