What's up with Safari 4?

Discussion in 'macOS' started by techie4life, Jun 25, 2009.

  1. techie4life macrumors 6502

    Joined:
    Jul 19, 2007
    Location:
    Georgia
    #1
    What's going on here? I installed Safari 4, and ever since this (below images) has been happening on several websites. It doesn't do it in Firefox, and it doesn't do it on every website, mainly just ones with a lot of listed items, like MacRumors or real estate listing websites. I am running OSX 10.5.7 on a 2.4GHz 2Gb RAM 320Gb iMac. Any ideas?

    [​IMG]
    [​IMG]

    EDIT: It just did it on the Flickr page when it was just one image!
     
  2. soup4you2 macrumors regular

    Joined:
    Apr 12, 2007
    #2
    Weird.. I haven't seen that one yet. I just get the constant crashing when there's flash or java/javascript present.
     
  3. ACiB708 macrumors regular

    Joined:
    Apr 6, 2008
    #3
    I hadn't seen that one... try resetting safari, closing and opening again (guess you have already done that), well try reinstalling. Let us know how that works out.
     
  4. OZMP macrumors 6502

    Joined:
    Feb 18, 2008
    #4
    I am running firefox 3.5beta on a dev build of OSX, and i have zero issues.... need i say more?
     
  5. åidån Guest

    Joined:
    Location:
    New Zealand
    #5
    I haven't had those weird colour issues, but it does crash all the damn time. I must've sent 30 crash reports now. I think it's mostly when I try to open a new tab and go to a site immediately after opening.
     
  6. techie4life thread starter macrumors 6502

    Joined:
    Jul 19, 2007
    Location:
    Georgia
    #6
    Actually I hadn't tried that, just restarting the computer, etc...resetting safari actually seems to have worked. I feel like an idiot now, but thanks!
     
  7. Razeus macrumors 601

    Joined:
    Jul 11, 2008
    #7
    I have to say that Safari 4 is garbage. I've tried using it extensively and it crashes more than it should, but I'm going to stick with Firefox.
     

Share This Page