What's wrong with my macbook?

Discussion in 'MacBook' started by Britney87, May 10, 2009.

  1. Britney87 macrumors newbie

    Joined:
    May 10, 2009
    #1
    Hi! I have a macbook a little over a year old. It's my first mac and I love it. Yesterday though it started acting really weird. I first noticed that it was really, really hot and the fan was running. I turned it off and back on and here's what I found out:

    Applications are being deleted from macbook. ITunes, IPhoto, iChat have clear question marks over icon. There are 8-10 blank spaces in the Applications folder where applications have been deleted. However, data is still there (ex. pictures still there, but no iPhoto).

    Internet= Says I have internet but wont connect.

    Cannot open " System Preferences" or "Internet Preferences".

    If connected to home computer will connect to internet and allowed to open internet preferences but still no system preferences.

    If shut down....takes a while to come back on and starts up 2-3 times.

    also "Preview" is gone. Now " ColorSync Utility" opens.

    Is this my hard drive dying? I'm tech challenged, so any help would be greatly appreciated.

    Thanks!
     
  2. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #2
    Try booting from the Leopard install dvd and running disk utility to check the disk.
     
  3. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #3
    I would start by backing everything up ASAP onto an external drive.
     
  4. andalusia macrumors 68030

    andalusia

    Joined:
    Apr 10, 2009
    Location:
    Manchester, UK
    #4
    Do this, for definate. You never know what it might start deleting next.
     
  5. Britney87 thread starter macrumors newbie

    Joined:
    May 10, 2009
    #5
    Thanks everyone. I have everything I want backed up already.

    I've just never experienced so I was hoping it pointed to a definite problem, ie. disk failure. But I guess not. So I'll run disk utility tonight.

    Thanks!
     
  6. Buskape macrumors 6502

    Buskape

    Joined:
    Dec 10, 2008
    Location:
    NGC 4889
  7. bearcatrp macrumors 68000

    Joined:
    Sep 24, 2008
    Location:
    Boon Docks USA
    #7
    Sounds like your hard drive got corrupted. Could be ready to crash. You wouldn't by chance be using file vault? My 1st G4 powerbook got corrupted using filevault and did the same thing yours is doing. Had to reformat and worked like a charm not using filevault.
     

Share This Page