Whats wrong with the charger?

Discussion in 'MacBook Pro' started by tdpartri, Jun 16, 2011.

  1. tdpartri macrumors newbie

    Joined:
    Jun 16, 2011
    #1
    Hey guys, Im having a frustrating problem. When i plug my magsafe into the port nothing happens. doesnt charge, light doesnt even come on. after i wiggle it it comes back on but it takes a while of wiggling. I did the hardware check that apples website gave me and it said my computer hardware was fine. My mac is 13in macbook pro mid 2010. Whats the problem?
     
  2. ratzzo macrumors 6502a

    ratzzo

    Joined:
    Apr 20, 2011
    Location:
    Madrid
    #2
    I have the same issue with mine, sort of. The small LED indicator on the charger doesn't turn on sometimes, but the battery shows as charging. Did you check if it's actually charging? It might just be a faulty LED inside the charger.
     
  3. Naimfan macrumors 68040

    Naimfan

    Joined:
    Jan 15, 2003
    #3
    Probably a bad connection in the wiring. Any sign of fraying?

    Best bet would be to replace it.
     
  4. tdpartri thread starter macrumors newbie

    Joined:
    Jun 16, 2011
    #4
    yeah when i plug it in no charge then i wiggle and if im lucky the led turns on and the computer calculates and then starts charging. my power supply is in great shape i take very good care of my things. no visual damage at all
     
  5. Naimfan macrumors 68040

    Naimfan

    Joined:
    Jan 15, 2003
    #5
    I'd probably take it in to the store and see if they'll replace it for you.
     

Share This Page