WhatsApp Background - Bad Battery Lifetime - iOS 10.3.3

Discussion in 'iOS 10' started by Chrisjmv, May 21, 2017.

  1. Chrisjmv macrumors newbie

    Joined:
    Apr 9, 2016
    #1
    Using ATM 10.3.3 Beta 1 on my iPhone 6S Plus which is completely new. Charged 2 times

    Battery life time is not as good as expected. WhatsApp background activity as you can see on the pictures.

    Not only one push, background sync is enabled. Absolutely nothing! Clean fresh install with some apps that are all up to date. What can I do against this WhatsApp activity by not deleting the app?

    [​IMG]

    [​IMG]
     
  2. dn1978 macrumors newbie

    Joined:
    Dec 14, 2016
  3. Chrisjmv thread starter macrumors newbie

    Joined:
    Apr 9, 2016
    #3
    How are your battery running times? Also a bit too low for a 6S (Plus?)
     
  4. deep1 macrumors regular

    Joined:
    Mar 29, 2011
    #4

    Turn off the Privacy-Contact for Whatsapp, i mentioned this long time back time too. It seems like when Whatsapp have access to contact it keep syncing it background or something.

    It is a minor inconvenience but it helps a lot with battery.
     
  5. Chrisjmv thread starter macrumors newbie

    Joined:
    Apr 9, 2016
    #5
    Okay thank you very much. Does it completely stop the background activity from WhatsApp?

    Can you post a screenshot of yours battery consumption please to compare it?
     
  6. deep1 macrumors regular

    Joined:
    Mar 29, 2011
    #6
    It doesn't completely stop but doesn't go into hours of background. My battery life is so much better since I did this.
     

    Attached Files:

  7. Chrisjmv thread starter macrumors newbie

    Joined:
    Apr 9, 2016
    #7
    Looks nice. IPhone 6S plus or 7?
     
  8. deep1 macrumors regular

    Joined:
    Mar 29, 2011
    #8
    7 plus.
     
  9. chillenandy321 macrumors regular

    chillenandy321

    Joined:
    Sep 19, 2013
    Location:
    Orlando, Florida
    #9
    How do you turn this off? Was looking in settings. Thank you
     
  10. deep1 macrumors regular

    Joined:
    Mar 29, 2011
    #10
    It is in iPhone setting either privacy or whatsapp app from setting.
     

    Attached Files:

  11. Chrisjmv thread starter macrumors newbie

    Joined:
    Apr 9, 2016
    #11
    Did all the settings and still heave background usage. Contacts stuff from WhatsApp also disabled...
    [​IMG]

    [​IMG]
     
  12. Mammut macrumors member

    Mammut

    Joined:
    Jun 9, 2015
    Location:
    Frankfurt, Germany
    #12
    Are you heavily using WhatsApp Web or WhatsApp on Mac? Using (just have it open / running on the MacBook) makes my iPhone Batterylife worse!
     
  13. Chrisjmv thread starter macrumors newbie

    Joined:
    Apr 9, 2016
    #13
    Never used WhatsApp WEB so this it can't be.
     
  14. deep1 macrumors regular

    Joined:
    Mar 29, 2011
    #14
    Also keep in mind, if you make lots of calls that counts as background usage too.
     
  15. cswifx Suspended

    cswifx

    Joined:
    Dec 15, 2016
    #15
    How many messages do you receive on average per day? I've noticed that the more messages you receive, the more WhatsApp seems to stay in the background.
    Also I've done the disabling contacts trick, it didn't seem to work.
     
  16. Chrisjmv thread starter macrumors newbie

    Joined:
    Apr 9, 2016
    #16
    Well. I get a lot. Maybe that's the reason why.


    But never had that much before. Older WhatsApp version never seen so much background usage or am I wrong with this?
     
  17. cswifx Suspended

    cswifx

    Joined:
    Dec 15, 2016
    #17
    It's always been this much for me, ever since I started receiving a lot more messages.
     
  18. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #18
    Apps such as WhatsApp can stay active in the background to listen for incoming VoIP calls. This isn’t something you can control in iOS settings. Apps can also be woken up in the background as push notifications arrive. The only thing you can do there is turn off ‘background app refresh’, if you haven’t already done so.

    I don’t find the energy consumption particularly concerning, looking at the screenshots. You do seem to spend quite a bit of time in WhatsApp and the foreground/background activity may effectively be cumulative.
     

Share This Page