iPad When an app causes safe mode, and uninstalling doesn't fix it

Discussion in 'Jailbreaks and iOS Hacks' started by wildonrio, Jan 25, 2014.

  1. wildonrio macrumors 6502

    Joined:
    Aug 15, 2008
    #1
    Installed Iconoclasm which caused safe mode immediately. I uninstalled it but no respring will get me out of safe mode. If I'm sure iconoclasm caused it, and uninstalling it isn't the fix, then what else can I do?
     
  2. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #2
    Install Crash Reporter from Cydia. Open it, install the suggested package. Reboot. Open Crash Reporter. Open the crash report for Springtomize. Find out what thread crashed. See what subprocesses are in that thread. Report back.
     
  3. wildonrio thread starter macrumors 6502

    Joined:
    Aug 15, 2008
    #3
    Thanks for offering assistance. I got up until "Open the crash report for Springtomize" (which I assume you meant Iconoclasm). There are no reports in the app. It's just blank.
     
  4. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #4
    Can you show a screenshot of what it looks like to you?
     
  5. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #5
    Did you remove any dependencies from that tweak also?
     
  6. braddick macrumors 68040

    braddick

    Joined:
    Jun 28, 2009
    Location:
    Encinitas, CA
    #6
    IconSupport is also downloaded with iconoclasm and that is your main issue.

    Delete it, reboot- and you should be all set.
     
  7. wildonrio, Jan 25, 2014
    Last edited: Jan 25, 2014

    wildonrio thread starter macrumors 6502

    Joined:
    Aug 15, 2008
    #7
    I was very hopeful for your suggestion as it seemed logically correct. I checked, however, and IconSupport was not included with Iconoclasm. Here is what I have installed:

    BigBoss Icon Set
    Cydia Installer
    Cydia Substrate
    Cydia Translations
    evasi0n 7.x Untether
    GBC.emu
    iFile
    MD.emu
    NES.emu
    OpenSSH
    RetroArch
    Snes9x EX+
    SpringBoard Access
    Substrate Safe Mode
     
  8. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #8
    What did you have set for your view settings? User?
     
  9. wildonrio, Jan 26, 2014
    Last edited: Jan 26, 2014

    wildonrio thread starter macrumors 6502

    Joined:
    Aug 15, 2008
    #9
    Yes. Appreciate your help by the way!

    I switched it to Hacker and there's a lot more stuff in there now...all in Cydia/Telesphoreo so all of it necessary I assume.
     
  10. braddick macrumors 68040

    braddick

    Joined:
    Jun 28, 2009
    Location:
    Encinitas, CA
    #10
    You have to view it in 'expert' (top right on the Cydia page) instead of 'simple'.
    It will show up then.

    At minimum, under 'search' look for it and it will also tell you if it is on your device (it'll state, 'modify' in the upper right).
     
  11. wildonrio, Jan 26, 2014
    Last edited: Jan 26, 2014

    wildonrio thread starter macrumors 6502

    Joined:
    Aug 15, 2008
    #11
    It worked. You saved me hours of headaches restoring my iPad. Do you have a PayPal or something I could support you? Thank you!

    By the way, this is why jailbreaking seems to slowly destroy your device the more apps your try out: when you uninstall something but it still leaves behind traces of itself. Good grief, Iconoclasm developer and whoever else lets this happen.
     
  12. braddick macrumors 68040

    braddick

    Joined:
    Jun 28, 2009
    Location:
    Encinitas, CA
    #12
    My sincere pleasure.
    This forums gives me way more than I repay.

    Glad it worked out.
     

Share This Page